Arduino issues

Discussion in 'Linux Ubuntu' started by Capstan, Feb 17, 2014.

  1. Capstan

    Capstan New Member

    Feb 14, 2014
    Likes Received:
    I installed Linaro Ubuntu 12.04 LTS on a SD card, and managed to get a VNC desktop up and running so that I wouldn't be tying up my only monitor. A bit laggy but serviceable. ... -ubuntu-12

    I tried running Arduino via the icon on the desktop and that does bring up the IDE.

    Unfortunately I don't appear to be able to compile a basic sketch. I am seeing the problem described here;

    Is the IDE java-based? When I try running java by itself (java -version) I get an error;
    Couldn't allocate the heap
    try reducing the max heap size

    So I tried setting the minimum and maximum heap size manually and was able to at least get it to run;
    java -Xms4M -Xmx5M -version

    This tells me that the default heap settings for the installed Java are too large but I don't know how to change that.

    So then I decided to try installing what may be a more recent Arduino environment via these instructions;

    The first step is to download and unpack "Oracle JDK (Linux ARM v6/v7 Hard Float ABI)" which I did. But when I unpacked it and went into the bin directory I can't execute anything there;
    ubuntu@udoo: ./java -version
    bash: ./java: No such file or directory

    Which is odd, because the file is definitely there. Googling around, apparently this misleading error message can occur when you are trying to execute something that requires hardware floating point and you have only software FP? I downloaded and installed the Soft Float ABI version of Java and that does appear to run. We don't have hardware floating point?

    At any rate, after I installed the new Java and performed the "update-alternatives" commands I opened up the Arduino IDE from the desktop icon again and lo, this time it was able to compile a basic sketch and appeared to load it. The sketch merely toggles voltage on a pin to light an LED, and I don't happen to have an LED at present or even a voltmeter, but at least it doesn't crash. I'll get a cheap voltmeter at next opportunity.

    It turns out that the installed Arduino IDE is version 0154 so I guess there's no need to upgrade and besides, the oneI downloaded is "hfp" which probably requires hardware FP.
  2. extream96

    extream96 New Member

    Jun 27, 2014
    Likes Received:
    arduino ide is java-based, i have the same problem when i using both arduino and the browser, because java use very memory. if you can make a new sd, and you can retry to run only arduino ide.

Share This Page