avr/io.h error: UDOO Quad Board Package up to date?

Discussion in 'UDOO QUAD' started by pdblood, Jul 18, 2019.

  1. pdblood

    pdblood New Member

    Joined:
    Apr 7, 2014
    Messages:
    12
    Likes Received:
    0
    One of the libraries I am using has this include statement:

    #include <avr/io.h>

    Code:
    Attempting to build with that library results in this error:
    Arduino: 1.8.9 (Windows Store 1.8.21.0) (Windows 10), Board: "UDOO QDL (Arduino Due)"
    
    Build options changed, rebuilding all
    C:\Users\pdblo\Box Sync\Personal\Arduino\libraries\PS2X_lib\PS2X_lib.cpp:5:20: fatal error: avr/io.h: No such file or directory
    
     #include <avr/io.h>
    
                        ^
    
    compilation terminated.
    
    exit status 1
    
    This link below indicates that the error requires an update of the board package for Arduino Due:
    https://github.com/adafruit/Adafruit-GFX-Library/issues/121

    When I follow the instructions in the UDOO Quad official docs and add the json file that it points me to, the latest board package for UDOO Quad is 1.6.7. Does this board package need to be updated?

    Phil
     
    Last edited by a moderator: Aug 7, 2019

Share This Page