Bolt V8 wont start seems dead

Discussion in 'UDOO BOLT' started by William Whelan, Mar 28, 2020.

  1. William Whelan

    William Whelan New Member

    Aug 7, 2019
    Likes Received:

    I have a Bolt V8 with a udoo supplied power supply. I had it up and running with Linux and hadn't used it because I was waiting to purchase the metal case which arrived last week.
    I inserted the unit into the metal case and attached the power button. I finished the case assembly and added power to the unit. The little bolt symbol on the case lit in an orange colour and the button would not power on the unit.
    I stripped the case down again and tried to power on the unit with the microswitch and it will not power on.
    There are no LEDs lit on the board.
    I removed my M.2 chip also to bring the board back to basics and it still wont start and still no LEDs lit.
    There is a green power LED on the power block. This is normally lit. When I plug it into the Bolt it starts to flash.
    Thinking it might be a power supply, I use a compatible Dell power supply and same story, no LEDs on the board and it wont start.

    Any help appreciated

Share This Page