Ethernet port not working

Discussion in 'UDOO X86' started by sekarpdkt, May 7, 2017.

Tags:
  1. sekarpdkt

    sekarpdkt New Member

    Joined:
    May 7, 2017
    Messages:
    18
    Likes Received:
    1
    Hi all
    Just received and installed Kubuntu 17.04. Ethernet port is not working. Any help?
     
  2. Maurice

    Maurice Active Member

    Joined:
    Oct 13, 2015
    Messages:
    394
    Likes Received:
    87
    What is the output of ethtool eth0? Especially, does it report a link is detected?
     
  3. sekarpdkt

    sekarpdkt New Member

    Joined:
    May 7, 2017
    Messages:
    18
    Likes Received:
    1
    Getting following error

    xxxxx@UDOO-x86:~$ sudo ethtool eth0
    Settings for eth0:
    Cannot get device settings: No such device
    Cannot get wake-on-lan settings: No such device
    Cannot get message level: No such device
    Cannot get link status: No such device
    No data available
     
  4. Maurice

    Maurice Active Member

    Joined:
    Oct 13, 2015
    Messages:
    394
    Likes Received:
    87
    What does lspci | grep -i eth output? It should tell something about the ethernet controller, if there is no output no controller is seen. If that is the case, I'd contact customer support, or try another distribution, like plain Ubuntu.
     
  5. jj_0

    jj_0 New Member

    Joined:
    Apr 5, 2017
    Messages:
    7
    Likes Received:
    6
    It could als be that the ethernet port isn't called eth0 anymore as systemd names the ethernet port differently. E.g. on my 17.04 laptop the ethernet port is enp2s0f1. If you do an ifconfig you might see what the port is called.
     
    Maurice likes this.
  6. Maurice

    Maurice Active Member

    Joined:
    Oct 13, 2015
    Messages:
    394
    Likes Received:
    87
    My 17.04 still calls it eth0, but yes, it might have a different name. Use ifconfig -a , otherwise it might skip inactive interfaces.
     
  7. sekarpdkt

    sekarpdkt New Member

    Joined:
    May 7, 2017
    Messages:
    18
    Likes Received:
    1
    Some info as asked for.. No luck... As i have not received both antenna also, it is very difficult to use now.

    xxxxx@UDOO-x86:~$ sudo lspci
    00:00.0 Host bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SoC Transaction Register (rev 35)
    00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller (rev 35)
    00:13.0 SATA controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SATA Controller (rev 35)
    00:14.0 USB controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series USB xHCI Controller (rev 35)
    00:1a.0 Encryption controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Trusted Execution Engine (rev 35)
    00:1b.0 Audio device: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Definition Audio Controller (rev 35)
    00:1c.0 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #1 (rev 35)
    00:1c.3 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #4 (rev 35)
    00:1f.0 ISA bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCU (rev 35)
    00:1f.3 SMBus: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx SMBus Controller (rev 35)
    02:00.0 Network controller: Intel Corporation Device 24fb (rev 10)
    xxxxx@UDOO-x86:~$ sudo ifconfig -a
    lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
    inet 127.0.0.1 netmask 255.0.0.0
    inet6 ::1 prefixlen 128 scopeid 0x10<host>
    loop txqueuelen 1000 (Local Loopback)
    RX packets 539 bytes 40350 (40.3 KB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 539 bytes 40350 (40.3 KB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    wlp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet 192.168.0.148 netmask 255.255.255.0 broadcast 192.168.0.255
    inet6 fe80::d299:c127:e3da:bb97 prefixlen 64 scopeid 0x20<link>
    ether 30:e3:7a:65:2d:9f txqueuelen 1000 (Ethernet)
    RX packets 31207 bytes 33917063 (33.9 MB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 24509 bytes 3269793 (3.2 MB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
     
  8. Maurice

    Maurice Active Member

    Joined:
    Oct 13, 2015
    Messages:
    394
    Likes Received:
    87
    I can see only two network interfaces, local loopback ('lo') and the wireless network (wlp2s0). Your system does not seem aware of any ethernet (enXXXX) network interface.

    You could try installing a different operating system to exclude the possibility that it is an OS problem. If that fails, you should contact customer support.
     
    waltervl likes this.
  9. sekarpdkt

    sekarpdkt New Member

    Joined:
    May 7, 2017
    Messages:
    18
    Likes Received:
    1
    I tried with Ubuntu 17.04 as well as 16.04. Same status. Contacting customer care
     
  10. bodgyuk

    bodgyuk New Member

    Joined:
    Apr 26, 2017
    Messages:
    29
    Likes Received:
    3
    While this is a long shot, what kernel version is your Ubuntu using? It might not have the driver for this particular Intel controller.

    Without rebooting my system, I can't recall if the ethernet function can be disabled in BIOS, might be worth a check though.
     
  11. Maurice

    Maurice Active Member

    Joined:
    Oct 13, 2015
    Messages:
    394
    Likes Received:
    87
    I installed 17.04, and no network problem (well, almost, not UDOOs fault). I had to use ip instead of ifconfig, because the latter is deprecated....

     
  12. sekarpdkt

    sekarpdkt New Member

    Joined:
    May 7, 2017
    Messages:
    18
    Likes Received:
    1
    No luck

    Code:
    sekar@UDOO-x86:~$ ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host
           valid_lft forever preferred_lft forever
    2: wlp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
        link/ether 30:e3:7a:65:2d:9f brd ff:ff:ff:ff:ff:ff
        inet 192.168.0.148/24 brd 192.168.0.255 scope global dynamic wlp2s0
           valid_lft 86357sec preferred_lft 86357sec
        inet6 fe80::ee3f:9502:deb0:80ce/64 scope link
           valid_lft forever preferred_lft forever
    sekar@UDOO-x86:~$ sudo systemctl status networking.service
    [sudo] password for sekar:
    ● networking.service - Raise network interfaces
       Loaded: loaded (/lib/systemd/system/networking.service; enabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Sat 2017-05-13 13:05:32 IST; 58s ago
         Docs: man:interfaces(5)
     Main PID: 889 (code=exited, status=1/FAILURE)
    
    May 13 13:05:32 UDOO-x86 ifup[889]: than a configuration issue please read the section on submitting
    May 13 13:05:32 UDOO-x86 ifup[889]: bugs on either our web page at www.isc.org or in the README file
    May 13 13:05:32 UDOO-x86 ifup[889]: before submitting a bug.  These pages explain the proper
    May 13 13:05:32 UDOO-x86 ifup[889]: process and the information we find helpful for debugging..
    May 13 13:05:32 UDOO-x86 ifup[889]: exiting.
    May 13 13:05:32 UDOO-x86 ifup[889]: Failed to bring up enp2s0.
    May 13 13:05:32 UDOO-x86 systemd[1]: networking.service: Main process exited, code=exited, status=1/FAILURE
    May 13 13:05:32 UDOO-x86 systemd[1]: Failed to start Raise network interfaces.
    May 13 13:05:32 UDOO-x86 systemd[1]: networking.service: Unit entered failed state.
    May 13 13:05:32 UDOO-x86 systemd[1]: networking.service: Failed with result 'exit-code'.
    sekar@UDOO-x86:~$ sudo cat /etc/network/interfaces
    # interfaces(5) file used by ifup(8) and ifdown(8)
    auto lo
    iface lo inet loopback
    
    auto enp2s0
    iface enp2s0 inet dhcp                                                                                                                                                  
                                                                                                                                                                           
    sekar@UDOO-x86:~$                                                                                                                                                      
                            
     
  13. ccs_hello

    ccs_hello UDOOer

    Joined:
    Apr 15, 2017
    Messages:
    535
    Likes Received:
    194
    Since running the
    lspci
    command did not show the Realtek RT8111 Ethernet Controller device,
    your board has a hardware problem.
     
  14. sekarpdkt

    sekarpdkt New Member

    Joined:
    May 7, 2017
    Messages:
    18
    Likes Received:
    1
    Got replacement board and Ethernet works. Thanks for the original hint

    Code:
    sekar@UDOO-x86:~$  sudo lspci
    [sudo] password for sekar:
    00:00.0 Host bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SoC Transaction Register (rev 35)
    00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller (rev 35)
    00:13.0 SATA controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SATA Controller (rev 35)
    00:14.0 USB controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series USB xHCI Controller (rev 35)
    00:1a.0 Encryption controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Trusted Execution Engine (rev 35)
    00:1b.0 Audio device: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Definition Audio Controller (rev 35)
    00:1c.0 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #1 (rev 35)
    00:1c.2 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #3 (rev 35)
    00:1c.3 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #4 (rev 35)
    00:1f.0 ISA bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCU (rev 35)
    00:1f.3 SMBus: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx SMBus Controller (rev 35)
    02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
    03:00.0 Network controller: Intel Corporation Device 24fb (rev 10)
    sekar@UDOO-x86:~$
    
    
     

Share This Page