iommu disabled by default, kernel complains?

Discussion in 'UDOO BOLT' started by rdslw, May 16, 2020.

  1. rdslw

    rdslw UDOOer

    Joined:
    Apr 5, 2014
    Messages:
    30
    Likes Received:
    10
    Udoo bolt default BIOS settings has IOMMU disabled.

    Because of that, linux kernel complains upon boot:
    [ 2.190274] kfd kfd: Allocated 3969056 bytes on gart
    [ 2.191331] kfd kfd: error getting iommu info. is the iommu enabled?
    [ 2.191339] kfd kfd: Error initializing iommuv2
    [ 2.191556] kfd kfd: device 1002:15dd NOT added due to errors


    Any ideas about enabling iommu without kernel hanging?
     

Share This Page