LVDS 7" set up problem

Discussion in 'Troubleshooting' started by Lorenzo.MdpTech, Oct 28, 2016.

  1. Lorenzo.MdpTech

    Lorenzo.MdpTech New Member

    Joined:
    Oct 25, 2016
    Messages:
    8
    Likes Received:
    3
    Hello,
    i've just bought some LVDS 7" for Quad (which is my board), i've followed the istructions for setting them up, but nothing shows up on the screen.
    So, first of all I've established the connection between my pc and the board with putty (Windows), then I physically connect the LVDS, I insert the micro sd with android flashed inside (everything works if i try with the HDMI so i think it isn't an android problem), I plug the current (original UDOO power supply) and finally I stop the normal boot procedure from putty console.
    Here what the console says:

    __________________________________________________
    CPU: Freescale i.MX6Q rev1.2 at 792 MHz
    CPU: Temperature 40 C
    Reset cause: POR
    Board: UDOO Quad
    Watchdog enabled
    DRAM: 1 GiB
    MMC: FSL_SDHC: 0
    *** Warning - bad CRC, using default environment

    No panel detected: default to HDMI
    Display: HDMI (1280x720)
    In: serial
    Out: serial
    Err: serial
    check_and_clean: reg 0, flag_set 0
    Fastboot: Normal
    flash target is MMC:0
    Net: using phy at 6
    FEC [PRIME]
    Normal Boot
    Hit any key to stop autoboot: 0
    =>

    ________________________________

    I noticed that in the video tutorial from UDOO the screen has a white light in the moment he plugs the power, mine doesn't do anything.

    After that I've set the output to the LVDS following the commands provided by Udoo in the LVDS setup page

    I write saveenv, and then boot.

    From the putty console I can see that the device can't find the LVDS and if I manually reboot from the button the watchdog restart continuosly the board.

    I have to flash again the SD to reset the settings and then it starts to work again with the HDMI as it normally does.
     
    Last edited by a moderator: Nov 3, 2016
  2. waltervl

    waltervl UDOOer

    Joined:
    Dec 12, 2015
    Messages:
    2,096
    Likes Received:
    532
    Udoobuntu or Android? Which version?

    Edit: I read Android. What version? Personally I cannot help but perhaps others with Android can give you tips
     
    Lorenzo.MdpTech likes this.
  3. Lorenzo.MdpTech

    Lorenzo.MdpTech New Member

    Joined:
    Oct 25, 2016
    Messages:
    8
    Likes Received:
    3
    Android 6.0.1 marshmallow, for Udoo Quad, the one available at this link.
    It worked with the HDMI computer screen
     
    Last edited by a moderator: Nov 3, 2016
  4. Andrea Rovai

    Andrea Rovai Well-Known Member

    Joined:
    Oct 27, 2014
    Messages:
    1,703
    Likes Received:
    240
    Lorenzo.MdpTech likes this.
  5. Lorenzo.MdpTech

    Lorenzo.MdpTech New Member

    Joined:
    Oct 25, 2016
    Messages:
    8
    Likes Received:
    3
    It works, i wasted a lot of time trying to set the output throught serial and the answer was so easy :eek:
    Thanks a lot!
     
    Andrea Rovai and waltervl like this.

Share This Page