Microphone not working on Udoo Bolt Gear

Discussion in 'UDOO BOLT' started by alex k, Aug 3, 2020.

  1. alex k

    alex k New Member

    Joined:
    Aug 3, 2020
    Messages:
    1
    Likes Received:
    0
    Hello all, just got my Udoo Bolt Gear up and running with debian 10.5. But I can't seem to get the microphone jack working.

    I have a microphone with a TRRS connection, which connects to other devices, but when I plug it in the udoo microphone jack, nothing shows up in the settings of the input sound.
     
  2. michael yurkoski

    michael yurkoski New Member

    Joined:
    Jul 18, 2021
    Messages:
    3
    Likes Received:
    0
    I too have this issue. I plug in a microphone, and have tried both T/S and T/R/R/S and it simply "detects" and enables a stereo output with no microphone. I cannot seem to get it set to a microphone input.

    Is there any way to force this "headset" port to an input? I need it to be a microphone input for my application.


    Thanks!
    MJY
     
  3. ccs_hello

    ccs_hello UDOOer

    Joined:
    Apr 15, 2017
    Messages:
    529
    Likes Received:
    193
  4. NickGR

    NickGR UDOOer

    Joined:
    Jun 23, 2020
    Messages:
    59
    Likes Received:
    15
    I am using Buster Debian and microphone input works out of the box, though the problem for me is as I have no HDMI audio and using the audio jacks, but can not switch between the speaker (rear jack) to the TRRS (front output) like I do in Windows 10, though have not tinkered with it enough yet to get the audio config working properly.
     
  5. michael yurkoski

    michael yurkoski New Member

    Joined:
    Jul 18, 2021
    Messages:
    3
    Likes Received:
    0
    CCS, i did ensure that the correct pinout was used (CTIA, not OMTP). However, this application has a custom TRRS harness, so I need to looks further into the detection standard, to ensure the impedances match what we're trying to do.
     

Share This Page