OpenGL mystery (sort of) resolved. Read this.

Discussion in 'General Discussion' started by Patola, Nov 6, 2013.

  1. Patola

    Patola New Member

    Oct 20, 2013
    Likes Received:
    Hello, all. I have had a problem with my UDOO with OpenGL that I report here. Basically, UDOO would stop updating the screen (even the cursor) whenever I ran something that used OpenGL or OpenGL/ES. I struggled with it a lot, then I started a few tests to find out the reason.

    First I installed Android in a spare MicroSD. OpenGL/ES worked correctly (played some 3D games downloaded from

    Then I installed a fresh copy of Linaro image 1.2 and it also worked.

    As I always do an update & upgrade after I install my ARM devices, I figured an update could have broken something. So I got a listing of all packages and versions on the working and non-working copy of linaro using this line of shell script:
    dpkg -l | awk '($1=="ii") {print $2, $3}' | sort > output.txt
    And then I compared them using "meld" on my Ubuntu. I have marked a dozen suspect packages and in the working copy, I installed dpkg-repack and dumped the installed versions to .debs.

    I booted my non-working copy and downgraded the GL driver packages. Rebooted and tried OpenGL; it did not work.
    Then I downgraded the X11 packages. Rebooted and tried OpenGL, and it worked!

    These are the GL driver packages (whose downgrade did not make any difference):
    -rw-r--r--  1 ubuntu ubuntu 1708278 Nov  6 21:22 libegl1-mesa-drivers_7.11-0ubuntu3_armel.deb
    -rw-r--r--  1 ubuntu ubuntu   45770 Nov  6 21:22 libegl1-mesa_7.11-0ubuntu3_armel.deb
    -rw-r--r--  1 ubuntu ubuntu 3270254 Nov  6 21:22 libgl1-mesa-dri_7.11-0ubuntu3_armel.deb
    -rw-r--r--  1 ubuntu ubuntu  118908 Nov  6 21:22 libgl1-mesa-glx_7.11-0ubuntu3_armel.deb
    -rw-r--r--  1 ubuntu ubuntu   33984 Nov  6 21:22 libglapi-mesa_7.11-0ubuntu3_armel.deb
    -rw-r--r--  1 ubuntu ubuntu    9480 Nov  6 21:22 libgles2-mesa_7.11-0ubuntu3_armel.deb
    -rw-r--r--  1 ubuntu ubuntu  149750 Nov  6 21:22 libglu1-mesa_7.11-0ubuntu3_armel.deb
    -rw-r--r--  1 ubuntu ubuntu   11020 Nov  6 21:22 libopenvg1-mesa_7.11-0ubuntu3_armel.deb
    And these are the X11 packages I downgraded, which made OpenGL work:
    -rw-r--r--  1 ubuntu ubuntu   47824 Nov  6 21:22 x11-common_7.6+7ubuntu7_all.deb
    -rw-r--r--  1 ubuntu ubuntu    2788 Nov  6 21:22 xorg-dev_7.6+7ubuntu7_all.deb
    -rw-r--r--  1 ubuntu ubuntu    3018 Nov  6 21:22 xorg_7.6+7ubuntu7_armel.deb
    -rw-r--r--  1 ubuntu ubuntu   45144 Nov  6 21:22 xserver-common_1.10.4-1ubuntu4_all.deb
    -rw-r--r--  1 ubuntu ubuntu 1493096 Nov  6 21:22 xserver-xorg-core_1.10.4-1ubuntu4_armel.deb
    -rw-r--r--  1 ubuntu ubuntu  293970 Nov  6 21:22 xserver-xorg-dev_1.10.4-1ubuntu4_armel.deb
    -rw-r--r--  1 ubuntu ubuntu   31038 Nov  6 21:22 xserver-xorg-input-all_7.6+7ubuntu7_armel.deb
    -rw-r--r--  1 ubuntu ubuntu   52758 Nov  6 21:22 xserver-xorg-input-evdev_2.6.0-1ubuntu13_armel.deb
    -rw-r--r--  1 ubuntu ubuntu   31062 Nov  6 21:22 xserver-xorg-video-all_7.6+7ubuntu7_armel.deb
    -rw-r--r--  1 ubuntu ubuntu   32476 Nov  6 21:22 xserver-xorg_7.6+7ubuntu7_armel.deb
    In case anyone is interested, I am sharing a .zip of all these files in my google drive here, so to spare work for others.

    I don't know which specific X11 package broke OpenGL / OpenGL-ES functionality. To find this out, only by upgrading/downgrading packages individually. Now that I have 3D working, I am satisfied.

    Hope this helps others.
  2. Lifeboat_Jim

    Lifeboat_Jim New Member

    Sep 16, 2013
    Likes Received:
    Thanks Ptl, that is very helpful indeed!
  3. DracoLlasa

    DracoLlasa UDOOer

    Oct 15, 2013
    Likes Received:
    Yes thank you, Im sure this was a very time consuming investigation and we all really appreciate the work.
    Hopefully the Developers will catch this and try to find out whats going on so they can get it corrected if they can

    Thanks again
  4. killkrt

    killkrt New Member

    Nov 1, 2013
    Likes Received:

    As I've already wrote in another thread, I got some problems compiling and running a simply program made using the GLFW library.

    So I was wondering if this problem is due to the same reason. Since I've an empty SD, I could flash a clean image and try to test my code without make any update-upgrade.

    Anyway I'm afraid the problem is due to other stuff... :cry: I'll tell you how is going as soon I make the test!

    Thank you.

Share This Page