Struggling with the initial setup

Discussion in 'UDOO X86' started by Ivan Morgillo, Sep 30, 2017.

  1. Ivan Morgillo

    Ivan Morgillo New Member

    Apr 13, 2015
    Likes Received:
    Hi all, I'm one of the Kickstarter backers and just now I'm having the chance to setup my UDOO x86.

    In the initial attempts, I couldn't get a signal from the HDMI. I tried 2 different displays, one old and one recent, with no luck. Finally I managed to reach the BIOS menu using my projector, following some advices from the forum: "Use your TV". Well, I don't have a TV, but the projector worked well

    Unfortunately, I can't go anywhere from the BIOS menu. I can navigate the 6 buttons with keyboard or mouse, but if I click one or press enter on the selected one, nothing happens. I tried a USB and a wireless keyboard, getting same results.

    I'm also trying to boot Ubuntu from USB. I followed the instructions for Unetbootin and created a bootable disk with a couple of different versions, but no luck. When I power up the UDOO, I only get a black screen.

    I feel I'm stuck right now
    Any help, please?
  2. Maurice

    Maurice Active Member

    Oct 13, 2015
    Likes Received:
  3. YellowGTM

    YellowGTM Member

    Sep 21, 2017
    Likes Received:
    This happened to me as well. Try switching monitors. I had to use an HDMI to DVI adapter in order to use another monitor, but it worked.
    The reason is the UDOO cannot communicate with certain HDMI resolutions and just "Freezes" when you press any of the icons.

Share This Page