UDOO Bolt v8 GPU never above ~700MHz

Discussion in 'UDOO BOLT' started by Xudonax, Jul 26, 2020.

  1. Xudonax

    Xudonax UDOOer

    Joined:
    Jul 26, 2020
    Messages:
    1
    Likes Received:
    0
    For some reason my UDOO Bolt v8 doesn't want to run the GPU at more than approximately 700MHz. I'm on the latest Windows 10 (update 2004), latest AMD drivers (2.05.27.117 for the chipset, 20.30.00.05 for the GPU). BIOS is at version 1.08, and I did enable the 25W TDP power mode. I've also set the memory to automatically overclock, this causes it to run at 1200MHz or 2400MT/s. Temperatures are pretty decent at roughly 60 degrees, so that shouldn't be an issue either.

    See also the screenshots below. Is there anything else I can try to get it to the "advertised" 1100MHz that GPU-z says is normal for this chip?

    GPU-z:
    [​IMG]

    Windows Task Manager:
    [​IMG]
     
  2. NickGR

    NickGR UDOOer

    Joined:
    Jun 23, 2020
    Messages:
    11
    Likes Received:
    4
    I have the sme problem and think several people more looking for gaming on the Bolt at youtube and no solution yet, could be BIOS could be drivers, have not checked the clocks in Linux to know for sure.
     
  3. waltervl

    waltervl UDOOer

    Joined:
    Dec 12, 2015
    Messages:
    2,237
    Likes Received:
    561
    I have no windows but Linux (Ubuntu 20.04 LTS). but I had the same situation, the frequency was not higher than 700 MHz.
    I had to set the drm performance level to high with the following command:
    sudo sh -c "echo high > /sys/class/drm/card0/device/power_dpm_force_performance_level"
    If i now run glmark2 it will go to 1100MHz

    For more information see https://wiki.gentoo.org/wiki/AMDGPU
    I suppose on windows 10 there is also a power setting that enables the GPU performance
     

Share This Page