Udoo neo couldn't boot after copied new custom kernel to SD card

Discussion in 'UDOO NEO' started by baoson2211, Sep 3, 2019.

  1. baoson2211

    baoson2211 UDOOer

    Jul 23, 2017
    Likes Received:
    Hello everyone,
    I just received a Udoo board and started playing with it. In the beginning, everything is perfect. I flashed my SD card follow this link. It works well. The OS was booted successful and I can control the board via serial console as well as web interface.

    Unfortunately, I'm facing a trouble after tried to build a custom kernel and copy the new zImage file to SD card. Detail:
    I wanna write a driver to control HD44780 LCD via a PCF8574A IO expansion module. Follow the other guide, I regenerated configuration to enable PCF857x driver, modified device tree, then rebuilt zImage and device tree blob files. The compilation was successful and I just copied zImage and dtb files to SD card and reset the board. However, the red LED always light stable. I checked serial connection and found that boot process was stuck after u-boot completed its responsibility:

    U-Boot SPL 2015.04-21123-g7271b51 (Jul 22 2016 - 14:15:22)
    Setting 1024MB RAM calibration data
    port 1
    SPL: u-boot second stage will be loaded from MMC0
    U-Boot 2015.04-21123-g7271b51 (Jul 22 2016 - 14:15:22)
    CPU:   Freescale i.MX6SX rev1.2 at 792 MHz
    CPU:   Temperature 48 C
    Reset cause: POR
    Board: UDOO Neo Full
    I2C:   ready
    DRAM:  1 GiB
    PMIC:  PFUZE3000 DEV_ID=0x30 REV_ID=0x11
    MMC:   FSL_SDHC: 0, FSL_SDHC: 1
    *** Warning - bad CRC, using default environment
    In:    serial
    Out:   serial
    Err:   serial
    Net:   using phy at 0
    FEC0 [PRIME]
    Normal Boot
    Hit any key to stop autoboot:  0
    switch to partitions #0, OK
    mmc0 is current device
    reading uEnv.txt
    163 bytes read in 10 ms (15.6 KiB/s)
    Running bootscript from mmc ...
    Device Tree: dts/imx6sx-udoo-neo-full-hdmi-m4.dtb
    ## Error: "m4boot" not defined
    reading /zImage
    4237600 bytes read in 216 ms (18.7 MiB/s)
    Booting from mmc ...
    reading dts/imx6sx-udoo-neo-full-hdmi-m4.dtb
    46020 bytes read in 34 ms (1.3 MiB/s)
    Kernel image @ 0x80800000 [ 0x000000 - 0x40a920 ]
    ## Flattened Device Tree blob at 83000000
       Booting using the fdt blob at 0x83000000
       Using Device Tree in place at 83000000, end 8300e3c3
    Switched to ldo_bypass mode!
    Starting kernel ...
    I didn't see anything after the "Starting kernel ..." line.

    I'm a newbie and I don't have any experience to investigate this issue. I have searched for something similar in the forum but no one seems to have encountered my problem.

    Did I miss something? I wanna clarify that I'm only set CONFIG_GPIO_PCF857X in .config file, re-compile zImage and dtb files. Do I need to re-compile u-boot? And someone can tell me how to investigate when encountering similar problems, please?

    Thank you.
  2. Gorgo

    Gorgo UDOOer

    Nov 9, 2016
    Likes Received:
    Hi @baoson2211 , I hope it's not too late.
    I rebuilt many times the kernel with the guide you linked without problems.
    I guess you set CONFIG_GPIO_PCF857X during the step 'ARCH=arm make menuconfig'
    then you followed the others steps.

    Can I ask you the terminal log during all the rebuilding process? (from 'Load the default kernel configuration' to 'Copy the kernel to the SD card')?
  3. baoson2211

    baoson2211 UDOOer

    Jul 23, 2017
    Likes Received:
    Hi @Gorgo ,

    Yes, as you wrote, I set CONFIG_GPIO_PCF857X during the step 'ARCH=arm make menuconfig' then built kernel follows the others steps.
    Unfortunately, I didn't store terminal build log. I couldn't reproduce the issue because my previous neo board was broken.
    So now, I tried again with another board and the issue no longer exists. It seems that only appears on older one.

    Finally, Thanks for your reply. I will continue this thread if the problem appears again.
    Gorgo likes this.

Share This Page