Udoo X86 emmc not booting on uefi mode

Discussion in 'UDOO X86' started by Augusto Pederneiras, Apr 10, 2021.

  1. Augusto Pederneiras

    Augusto Pederneiras New Member

    Apr 9, 2021
    Likes Received:
    Hello guys,

    I am an owner of a Udoo x86 II Advanced Plus and after a reboot of my Udoo last week, it stopped booting my windows 10 (installed on 32gb emmc). Every time I started the board it went straight to efi shell (windows entry didn't show on the uefi boot list), but the emmc appeared on legacy option. So I began troubleshooting and did this:

    1. Tried to restore windows bootmanager using bcdedit on recovery.
    2. Tried reinstalling windows 10 (with multiple images and flash drives), the usb booted fine on uefi and installed successfully on the whole drive (I had no problems deleting all the partitions or in the installation process). However when rebooting the windows option wouldn't appear on boot menu.
    3. Tried disabling secure boot and TPM.
    4. Tried to install ubuntu (20.04 and 16.04), manjaro and debian but they all didn't recognized the emmc drive and throwed this error on dmesg: "error -22 whilst initialising mmc card"
    5. Tried to update the bios to last version 1.06 and it didn't changed anything.
    6. Tried installing windows in legacy mode. I've changed the boot mode to legacy only and changed the emmc controller from acpi to pci. Then I booted a windows 10 installation disk and converted gpt to mbr using this commands:
    select disk 0
    convert mbr
    After this, I've booted the installation disk again in legacy mode, but unfortunately I kept getting this error: "Windows cannot be installed to this disk. This computer's hardware may not support booting to this disk. Ensure the disk's controller is enabled in the computer's BIOS menu."
    7. I've tried multiple bios configurations using pci controller on uefi, and changing some acpi configurations.
    8. I've also plugged a microSd to test the controller and the efi shell recognized with no problem as a filesystem (fs0).

    Also, my efi shell map looks something like this when no usb drive is plugged in:
    blk0 - Block Device (Alias null)
    blk1 - Block Device (Alias null)
    blk2 - Block Device (Alias null)
    blk3 - Block Device (Alias null)
    In conclusion I find it very weird I am able to partition, create and read files on the emmc with no problem, but the problem is when rebooting the SO boot entry is not added to the bios menu. Also, the bios recognizes the device on legacy boot.

Share This Page