All sudo commands hang, and other weirdness

Discussion in 'Troubleshooting' started by thatdude624, Jun 21, 2016.

  1. thatdude624

    thatdude624 New Member

    May 31, 2016
    Likes Received:
    Hi all

    So yesterday I tried to restart my Java based server on my UDOO QUAD, which usually runs 24/7 and needs to run with sudo. However, the command to restart it wasn't working.

    Today I'm trying to find out what's going wrong, and it soon became clear that any command run with "sudo" doesn't work: after pressing enter the terminal doesn't respond, it doesn't even ask for a password, and CTRL-C doesn't abort it either.

    My first thought was that Linux went corrupt or something, so I took a different microSD card and installed a fresh UDOOBUNTU 2.0 onto it, let it boot for a while and when I tried to run "sudo apt-get update", it froze again in exactly the same way.

    This happens both on SSH terminals (through the web-based interface) and on desktop terminals through VNC. Changing the default passwords doesn't help. What's going on?

    Interestingly, "su" pretends to work, but rebooting with "su" and then "reboot now", or through the GUI, stops the VNC server, but the system stays on. All open terminals, including ones frozen by sudo, get that "rebooting NOW!" broadcast message, but non frozen terminals still let you enter commands after that, and they still work. running apt-get update through su also crashes on the first one it tries to update.

    Arduino doesn't work, software update doesn't work, SSH connects but does nothing (not even the welcome screen or username prompt, but web based terminal does still work), and most programs generally don't work either. I've tried reinstalling the OS several times, but it still won't fix it.

    here's some screenshots of the terminal through the web interface:
    Last edited: Jun 21, 2016

Share This Page