Arduino IDE not uploading anymore

Discussion in 'Troubleshooting' started by gusco, Oct 2, 2015.

  1. gusco

    gusco New Member

    Apr 21, 2014
    Likes Received:

    I've been using my UDOO Quad for almost a year and made various projects, all running well. Today everything seems broken. I'm using the Arduino IDE 1.5.4 with the patched bossac file all this time. Today I tried to install a library to the IDE, which seemed to fail (core-dependencies failure) when I tried to upload a sketch. Anyway I eventually removed it. From then, it's been three hours I've been trying to upload anything (even the empty sketch) to Arduino and nothing happens during the upload. The progress bar stays stuck after the compile and the log is stuck at:
    Sketch uses 10,012 bytes (1%) of program storage space. Maximum is 524,288 bytes.
    Forcing reset using 1200bps open/close on port /dev/ttyUSB0
    PORTS {/dev/ttyUSB0, /dev/ttyS0, } / {/dev/ttyUSB0, /dev/ttyS0, } => {}
    PORTS {/dev/ttyUSB0, /dev/ttyS0, } / {/dev/ttyUSB0, /dev/ttyS0, } => {}
    Uploading using selected port: /dev/ttyUSB0
    /home/user/Downloads/arduino-1.5.4/hardware/tools/bossac -i -d --port=ttyUSB0 -U true -e -w -v -b /tmp/build3473088195552727453.tmp/sketch_oct02a.cpp.bin -R
    I have tried of course to reset/erase the Atmel with the jumpers, unplug the USB, use another USB port, unplug power etc... Nothing seems to help so far.

    Please, anyone, I'm seriously desperate for some help.
  2. Andrea Rovai

    Andrea Rovai Well-Known Member

    Oct 27, 2014
    Likes Received:
    Dear gusco,
    my suggestion is to verify if the SAM3X is broken. Can you try by uploading a sketch from "inside Linux", not through the bossac file.
    In case it's broken contact the customer care.

Share This Page