Board not powering on, USB port beside DC port instantly gets too hot to touch

Discussion in 'UDOO X86' started by Detox_GG, Sep 14, 2017.

  1. Detox_GG

    Detox_GG New Member

    Aug 31, 2017
    Likes Received:
    Calling all geniuses!

    If anyone feels up to it, I could use some much needed help.. I know this is a long post.. BUT, have no fear, for I have done my best to keep my thoughts and progress thus far organized and in point form.

    Though, because I know people will be looking for it..
    TL : DR;
    Over night, My board seems to have developed a serious issue. It was shut off and left alone entirely, while i slept. Whether I get a green or yellow LED upon powering, the OS does not boot, and the bottom of the board heats up to a temp hotter than I can touch within the first 30 seconds of powering on. What does this mean? Am I going to need to send it in? Is it a short? Is it a blown fuse? Any help would be amazing, Thank you in advance!! More detail is obviously below.

    >> So, Here is the "Sitch":

    I have been happily using my UDOO x86 since I received mine... However, now all of a sudden, my board seems to be experiencing some very crazy issues.. I am hoping I can accurately explain this..​

    So, After taking my typical steps of plugging in my usb keyboard/trackpad combo thing and an AOC E1659Fwu USB3 portable monitor (as always. worked flawlessly for weeks before). I Proceeded to plug the barrel connector of my PSU into the DC port to power the board on.. when I noticed that the LED did not immediately turn green and start booting Win10..

    To my knowledge, not much with this setup has changed over the past few weeks, and I can say that I am almost certain nothing has changed AT ALL between the 9 hours that i turned it off , went to bed, and woke up today. I am all alone here..​
    >> Things I noticed right away and/or tried already since the issue arose:

    • My board was starting to emit a warm "plastic-like" smell, like a short was taking place or.. a fuse fried or something
    • Only the Yellow LED came on (usually immediately goes green in my experience when it is working correctly). It was always solid yellow, no matter what i tried (master switch and other buttons tried too, as well as holding down and various other stated combinations)
    • Within about the first 20 - 60 seconds of being plugged in, the USB 3.0 port beside the 12v DC Barrel port becomes ALARMINGLY hot!!
      like.. I am talking, accidentally touch the wrong spot behind the USB3.0 port (bottom of board), and get an instant blister on your finger kind of hot..

    • I got scared to leave it on for longer than 10-20 seconds at a time after this... As it was very clear, that the operating system was not booting, the temperature of the region under the board and between the Ethernet port and the DC port was VERRY hot within seconds, and I still had very little idea as to what the LED error codes were/meant. So i took it upon myself to do some research.. It didn't go well..
    • After my research, feeling like all that I had learned was more than likely totally irrelevant to me.. I Tried powering it on without RTC battery after 20 mins of it being powered off WITHOUT the RTC battery in. Noticed that the LED light was now solid green again, everything was "visually" looking back to normal, but sadly, did not boot into Win10. Again, within 20-30 seconds of being plugged in, below the USB3 port (beside the 12v DC port) got scolding hot...
    >> High-Res photos of my UDOO x86 & Other tidbits.. (in case it helps..)

    Here is a link to an online album of 6 high resolution photos of my board. I figured you may need to actually see it to tell what's wrong :p

    Udoo X86 ADVANCED - Support Pictures:
    [ ]

    (P.S. Ignore the Arduino Header leaning up against the heatsink right now. I had to yank that off for a second to get a broken piece of jumper wire out of the 12v hole after i made this original post, haven't had a chance to straighten the pins and slide the header back on yet.)
    >> Other Details:

    • I use a 12v, 3.0A DC Wall PSU.
    • I recently connected a small fan (almost exactly like the official one for the heatsink) that i salvaged from an old laptop, have had it connected a few days already.. However, It has never yet worked. I did some brief research and it was a pretty popular response that you need to modify the BIOS settings or else it will only spin if the temps reach over like.. 65-75C or something.. I felt lazy and gave up on it for the mean time, not yet having time to come back to it..
    • I previously had a 2-pin 12v cpu fan plugged directly into the 12v and ground pins of the arduino headers. Later, I altered the red wire to have a on/off switch half way through the length of it. Never experienced any issues with this setup.. in fact, I was only switching to the other fan to conform to a smaller size and to have the ability to use the controlled cpu fan molex port. Again, I have since had this old solution completely disconnected for over 2 days now.
    • A day or two ago I was messing around with one of my portable power banks that supports up to 16V DC (MAXOAK 36,000mAh - Silver) to see if it would allow me to make my UDOO 100% portable. It did, no issues experienced.. in fact, i used it for about 4 hours straight on the power bank..

    So, as you can see.. I am truly lost for words and my biggest downfall here is not having a strong enough grasp on the nitty gritty of electricity, circuit boards, and ridiculously small hardware..

    If anyone much more experienced than I could chime in and help me get through this.. or at least.. help me determine my next step.. it would be MUCH appreciated. I would like to know if i need to send this guy in sooner, rather than later..

    P.S. I have also sent a similar support ticket to the UDOO team themselves, but i hear it takes them easily a week sometimes to answer..

    Thanks everyone!
    Last edited: Sep 15, 2017
  2. ektor5

    ektor5 Administrator Staff Member

    Jul 1, 2013
    Likes Received:
    Applying more than 12V±5% to the board can severely damage the board. If you did it, maybe some component under the USB port could be broken due to this.

    Also, from the images, seems that both U22 and U35 are damaged and a capacitor near U35 (under the USB) is missing.

    I don't think this board is recoverable anymore, be more aware of your experiments and likely outcomes.

    Markus Laire likes this.
  3. Markus Laire

    Markus Laire Active Member

    Mar 9, 2017
    Likes Received:
    I tried to Google about "MAXOAK 36,000mAh - Silver". It seems that depending on model the DC output on barrel connector is 16.8V or 14.8V - both definitely too high for UDOO X86.

    EDIT/REWRITTEN: Some models also have "5V/9V/12V" USB-C charging port, and I doubt that that could be used to power UDOO X86 as USB charging spec is quite involved with starting from 5V and perhaps going to higher voltages. (But I don't really know much about this).

    But if you used the DC barrel connector and not USB, then it seems you definitely used too high voltage (14.8 or 16.8).
    Last edited: Sep 19, 2017

Share This Page