Bolt Arduino dropping off of USB

Discussion in 'Troubleshooting' started by Andrew Chatham, Jan 3, 2021.

  1. Andrew Chatham

    Andrew Chatham New Member

    Jan 3, 2021
    Likes Received:
    I've been using the Arduino on my Bolt and recently had it drop off of USB and not come back after a reboot. I followed the udoo instructions to disable the modem manager and shorted the reset pin, and the Arduino came back but then dropped off again as soon as I ran my sketch again (~3 seconds into running).

    I have it connected to a bunch of buttons and lights, plus a WS2812b LED strip with a separate 5V power supply (grounds tied). I ran a sketch animating the LED stirp overnight without any problems and haven't touched the hardware since. But my most recent edits send a lot more data over the serial port, so maybe that's killing it?

    I'll try to hardwire a reset button so I can experiment with this, but I'm curious if anyone has ideas of what could be kicking it off.

    Kernel messages around the dropoff:

    Jan 2 16:55:27 box kernel: [ 6366.746315] input: Arduino LLC Arduino Leonardo Mouse as /devices/pci0000:00/0000:00:08.1/0000:05:00.4/usb3/3-2/3-2:1.2/0003:2341:8036.0002/input/input19
    Jan 2 16:55:27 box kernel: [ 6366.805297] input: Arduino LLC Arduino Leonardo Keyboard as /devices/pci0000:00/0000:00:08.1/0000:05:00.4/usb3/3-2/3-2:1.2/0003:2341:8036.0002/input/input20
    Jan 2 16:55:27 box kernel: [ 6366.805408] hid-generic 0003:2341:8036.0002: input,hidraw0: USB HID v1.01 Mouse [Arduino LLC Arduino Leonardo] on usb-0000:05:00.4-2/input2
    Jan 2 16:55:43 box kernel: [ 6382.797086] pcieport 0000:00:01.6: AER: Corrected error received: 0000:00:01.0
    Jan 2 16:55:43 box kernel: [ 6382.797095] pcieport 0000:00:01.6: AER: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Receiver ID)
    Jan 2 16:55:43 box kernel: [ 6382.797101] pcieport 0000:00:01.6: AER: device [1022:15d3] error status/mask=00000040/00006000
    Jan 2 16:55:43 box kernel: [ 6382.797105] pcieport 0000:00:01.6: AER: [ 6] BadTLP
    Jan 2 16:56:01 box kernel: [ 6400.048478] usb 3-2: USB disconnect, device number 6

Share This Page