Cant see udoo android on adb devices

Discussion in 'Android' started by visal, Dec 17, 2013.

  1. visal

    visal New Member

    Jun 19, 2013
    Likes Received:
    I posted this earlier in troubleshooting, however, I now realize this might be a better forum to get help.
    The Problem: I am unable to see the udoo android on the adb devices (or ddms).
    The device manager shows that the drivers are installed properly (i.e. Android Phone > Android ADB Interface) but when I look for ADB devices, I cannot see the Udoo board. Please see attached image to understand what the device manager shows.
    The OTG was enabled in the settings on the android Udoo.
    I am working on a Udoo Quad and on a windows 7 64bit desktop with Android SDK version 22.3

    Any help in the manner will be greatly appreciated.

    Warm Regards,

    Attached Files:

  2. CMSweb Media

    CMSweb Media New Member

    Dec 22, 2013
    Likes Received:
    Have you changed the software switch in Android via Console? As described in the Starter Guide, at "3.2.6. Switching between modes" ?

    Then you get all these Android Devices in Windows. Has worked for me, except for the fact that I'm missing a driver for a device called "UDOO-MX6DQ". In the end ADB is still not working, ... will try on Ubuntu sone.
  3. ekirei

    ekirei Administrator

    Jun 14, 2013
    Likes Received:
    It seems like you switch correctly the usb otg bus to the external connector but you haven't accept the "Allow USB debugging?" dialog from Android on UDOO.
    If the dialog wasn't appeared try to unplug and re-plug the microUSB cable until the dialog appear (check also the "Always allow from this computer" box).

    Now you should see the udoo android on the adb devices.

    You can also now use an usefull app like adbWireless for connect your UDOO to a pc over Wi-Fi without cable.
  4. LukasErlinghagen

    LukasErlinghagen New Member

    Feb 12, 2014
    Likes Received:
    I had the same problem (UDOO not showing up when enumerating adb devices, but showing up correctly in the Windows device manager). After reinstalling/upgrading the OEM USB drivers, everything worked as expected.

    Instructions on how to upgrade the OEM drivers are here:

Share This Page