Community Yocto krogoth builds

Discussion in 'Yocto' started by graugans, Nov 7, 2016.

  1. modjo

    modjo Active Member

    Joined:
    Sep 29, 2014
    Messages:
    417
    Likes Received:
    127
    @graugans , after some test this morning (i also tested your build on udooQdl), the result :
    - uart debug is working on secoA62 and udooQdl
    - eth is not working on secoA62
    - usbTouch don't work on secoA62 but lvds7touch (i2c) work. On udooquad all work
    - uboot is not find at boot (for the 2 card)
    - lvds7 work on the 2 card (if i manually redefine the symbolic link to point to lvds7) and hdmi
    - arduino is working on udooQdl (programmed from host pc)
    - Qt5.6 work on udoo quad (don't test your tool-chain)
    - Qt5.7 work on seco
    I opened issues on github about that (on yours git).
    Otherwise, i would like to congratulate you another time for your amazing job :) and i'm sure all this issues will be resolve in the next day (or week).
     
  2. danielye

    danielye New Member

    Joined:
    Nov 29, 2016
    Messages:
    3
    Likes Received:
    1
    I tried QT toolchain on QT Creator 4.1.0. But have errors:
    can not find -lQT5Widgets
    can not find -lQT5Gui
    can not find -lQT5Core
    can not find -lGLESv2
    How to fix it?
     
  3. modjo

    modjo Active Member

    Joined:
    Sep 29, 2014
    Messages:
    417
    Likes Received:
    127
    It's a problem with the last build of meta qt5, try to add linux-oe-g++ in Qt mkspecs (option/kit for your card)
    [​IMG]
     
    danielye likes this.
  4. danielye

    danielye New Member

    Joined:
    Nov 29, 2016
    Messages:
    3
    Likes Received:
    1
    Thanks a lot. I can compile the QT program by your method.
    But when I copy the program to the board and run, it shows:

    root@udooneo:~/qtbin# ./test6
    This application failed to start because it could not find or load the Qt platform plugin "eglfs"
    in "".

    Reinstalling the application may fix this problem.
    Aborted

    How to solve the problem?
     
  5. modjo

    modjo Active Member

    Joined:
    Sep 29, 2014
    Messages:
    417
    Likes Received:
    127
    You need to configure your mobile device in qt creator to deploy directly in the card ( no need to use scp or cp to copy the bin in the card). Otherwise, when you launch your app from shell you need to add -platform eglfs or export it before. For example try : ./test6 -platform eglfs
     
  6. danielye

    danielye New Member

    Joined:
    Nov 29, 2016
    Messages:
    3
    Likes Received:
    1
    Thanks. I finally can run the qt program by deploying directly to the card.
     
    graugans likes this.
  7. cyrilf

    cyrilf Active Member

    Joined:
    Feb 19, 2015
    Messages:
    167
    Likes Received:
    47
    I still cannot build the imx-firmware personnaly (target: UDOO Quad):
    Code:
    WARNING: firmware-imx-1_5.4-r0 do_fetch: Failed to fetch URL git://git.freescale.com/imx/imx-firmware.git;branch=master;destsuffix=poky/build-qdl/tmp/work/cortexa9hf-neon-mx6qdl-poky-linux-gnueabi/firmware-imx/1_5.4-r0/firmware-imx-5.4/git, attempting MIRRORS if available
    ERROR: firmware-imx-1_5.4-r0 do_fetch: Fetcher failure: Fetch command failed with exit code 128, output:
    Cloning into bare repository 'poky/build-qdl/downloads/git2/git.freescale.com.imx.imx-firmware.git'...
    fatal: read error: Connection reset by peer
    
    ERROR: firmware-imx-1_5.4-r0 do_fetch: Function failed: Fetcher failure for URL: 'git://git.freescale.com/imx/imx-firmware.git;branch=master;destsuffix=poky/build-qdl/tmp/work/cortexa9hf-neon-mx6qdl-poky-linux-gnueabi/firmware-imx/1_5.4-r0/firmware-imx-5.4/git'. Unable to fetch URL from any source.
    ERROR: Logfile of failure stored in: poky/build-qdl/tmp/work/cortexa9hf-neon-mx6qdl-poky-linux-gnueabi/firmware-imx/1_5.4-r0/temp/log.do_fetch.15887
    ERROR: Task 2054 (poky/meta-fsl-arm/recipes-bsp/firmware-imx/firmware-imx_5.4.bb, do_fetch) failed with exit code '1'
    EDIT:
    After a clean and a rebuild, this is openssl-native package that cannot be compiled:
    Code:
    ERROR: openssl-native-1.0.2h-r0 do_configure: The perl module 'bignum' was not found but this is required to build openssl.  Please install this module (often packaged as perl-bignum) and re-run bitbake.
    ERROR: openssl-native-1.0.2h-r0 do_configure: Function failed: do_configure (log file is located at poky/build-qdl/tmp/work/x86_64-linux/openssl-native/1.0.2h-r0/temp/log.do_configure.1852)
    ERROR: Logfile of failure stored in: poky/build-qdl/tmp/work/x86_64-linux/openssl-native/1.0.2h-r0/temp/log.do_configure.1852
    ERROR: Task 1238 (virtual:native:poky/meta/recipes-connectivity/openssl/openssl_1.0.2h.bb, do_configure) failed with exit code '1'
    It doesn't mean imx-firmware is OK, it means that this isn't the only one.
    I tried this to fix this issue under Ubuntu:
    Code:
    sudo apt-get update
    sudo apt-get install libcrypt-openssl-bignum-perl
    That didn't work.
     
    Last edited: Dec 6, 2016
  8. modjo

    modjo Active Member

    Joined:
    Sep 29, 2014
    Messages:
    417
    Likes Received:
    127
    For the user that would to test yocto for neo with qt5.7 full (webengine, charts, quickcontrols2 ...) see under :
    link for yocto_neo_qt5_7
    link for sdk_qt5_7
    For information, can/spi and uart6 are enabled and working (tested). They have a bug for the moment with arduino programming, the first time you will upload a scketch on the card you will have an error. Reboot the card and after all work fine ...
    @graugans , parhaps you can stick this links at top in your post ?
     
  9. cyrilf

    cyrilf Active Member

    Joined:
    Feb 19, 2015
    Messages:
    167
    Likes Received:
    47
    I was finally able to compile the imx-firmware. Maybe the repo shut down for a while.
     
  10. graugans

    graugans Administrator Staff Member

    Joined:
    Sep 17, 2015
    Messages:
    328
    Likes Received:
    141
    I asked on the ML a while ago when it was also not available. I was told it was overloaded.

    Gesendet von meinem FP2 mit Tapatalk
     

Share This Page