Enabling the virtual consoles (tty1-6) on Ubuntu 18.04 (On UDOO X86 board)

Discussion in 'UDOO X86' started by Joe Schmoe, Aug 30, 2018.

  1. Joe Schmoe

    Joe Schmoe New Member

    May 19, 2018
    Likes Received:
    I have used the virtual conoles (tty1-6) for decades in various Linuxes. I recently installed Ubuntu 18.04 (Bionic Beaver) on the UDOO X86. Everything is fine, except that the VCs don't work. As far as I can tell, it is by design that people are now only supposed to use the GUI (like in Windows). I would like to be able to use the VCs.

    Note: I've noticed (from ps output) that a lot of the GUI processes are running on tty1, so I assume that the GUI gets launched from there)

    What I've tried:

    1) Ctrl/Alt/F1 (or 2 or 3 or ...). Nothing happens. By "nothing happens", I mean, literally, nothing happens. Note: I am familiar with one system where you can switch to the virtual consoles (from the GUI), and it really does switch, but the screen stays on the GUI. You can now type and you are typing on the virtual console, but the screen makes it look like you are still on the GUI. I mention all this to say that, no, this is not the case here. You are still typing into the GUI.

    2) (as root) chvt 1. Nothing happens. Prompt comes right back and nothing is changed.

    3) (as root) chvt 2. Process hangs until you hit Ctrl/C. Weird...!

    3) (as root) strace chvt 2. Lots of strace output, ending with something like:

    ioctl(3,VT_WAITACTIVE ...)

    and then it hangs (until you hit Cltr/C).

    Next, following some advice I found on this board, I tried editing the file:


    and uncommenting the first two active lines, which are:




    I tried first just uncommenting the first one, then rebooted, nothing change, so I then uncommented the second one as well, rebooted, again, no change.

    So, what to do? What is next?

Share This Page