Extremely poor WiFi performance on Udoo Gear

Discussion in 'UDOO BOLT' started by Stefan, Jun 25, 2020.

  1. Stefan

    Stefan UDOOer

    Joined:
    Jun 22, 2020
    Messages:
    12
    Likes Received:
    0
    Hi there, I am having very poor experience with the stock WiFi card in udoo bolt gear.

    Icmp to my router are approx 7 seconds (no mistake here) and connectivity fades to none in a distance of 3 meters from the router.

    Obviously, other devices work fine on this router on any of dozens Wifi I have, any radio, up to real transfer of 700mbit/s.

    So I have questions: is it known issue? Is it metal chassis so badly influencing the signal? I suspect antennas are same, bu maybe not and I connected 2.4 to 5ghz and the other opposite?

    I suspect I can use pigtail and connect external antenna, but happens I don't have one handy, will it fix the issue?

    Thank you and best regards.
     
  2. NickGR

    NickGR UDOOer

    Joined:
    Jun 23, 2020
    Messages:
    6
    Likes Received:
    4
    The Bolt Gear WiFi module should have two external antennas with it, one for WiFi and one for Bluetooth, should be connected as it does not have internal antennas on the module it self
     
  3. Stefan

    Stefan UDOOer

    Joined:
    Jun 22, 2020
    Messages:
    12
    Likes Received:
    0
    Thanks, will use ext antenna and recheck.
     
  4. waltervl

    waltervl UDOOer

    Joined:
    Dec 12, 2015
    Messages:
    2,224
    Likes Received:
    561
    I have the same housing and fixed the 2 antennas on the outer side on the bottom of the dark grey part.
     

Share This Page