Known Neo Arduino problems overview

Discussion in 'UDOO NEO' started by waltervl, Jul 2, 2016.

  1. waltervl

    waltervl Well-Known Member

    Joined:
    Dec 12, 2015
    Messages:
    1,199
    Likes Received:
    358
  2. waltervl

    waltervl Well-Known Member

    Joined:
    Dec 12, 2015
    Messages:
    1,199
    Likes Received:
    358
  3. waltervl

    waltervl Well-Known Member

    Joined:
    Dec 12, 2015
    Messages:
    1,199
    Likes Received:
    358
  4. cyrilf

    cyrilf Active Member

    Joined:
    Feb 19, 2015
    Messages:
    162
    Likes Received:
    45
    I compiled the last revision of the kernel with OpenEmbedded. The /dev/ttyMCC device disappeared.
     
  5. waltervl

    waltervl Well-Known Member

    Joined:
    Dec 12, 2015
    Messages:
    1,199
    Likes Received:
    358
    Please create a new Forum thread to discuss this new issue. This is only an overview topic.
    But you also created an github issue for this and although Arduino related it is a kernel issue and not an issue yet in the current Udoobuntu 2.1
     
  6. cyrilf

    cyrilf Active Member

    Joined:
    Feb 19, 2015
    Messages:
    162
    Likes Received:
    45
    The title "Known Neo Arduino problems overview" wasn't clear about UDOObuntu 2.1 related issues.
     
  7. waltervl

    waltervl Well-Known Member

    Joined:
    Dec 12, 2015
    Messages:
    1,199
    Likes Received:
    358
    You are correct, it is also not mentioned in the opening topic that I keep up to date. But the intention is to support Arduino IDE users on a Udoo supported image. I will update the opening post.

    In the meanwhile it is good to know that things will fail on a development environment so it can be repaired before it will be released.
     
  8. waltervl

    waltervl Well-Known Member

    Joined:
    Dec 12, 2015
    Messages:
    1,199
    Likes Received:
    358
    Issue 8 (see start topic) solved.
     
  9. waltervl

    waltervl Well-Known Member

    Joined:
    Dec 12, 2015
    Messages:
    1,199
    Likes Received:
    358
    Updated first post (library porting info).

    Moreover I wish there was some movement in the Udoo team to help all the owners to solve these issues and have the Udoo Neo used where it was designed for. For now you far better buy an old Raspberry Pi and an Arduino Uno seperately.
     
    Last edited: Mar 18, 2017
  10. waltervl

    waltervl Well-Known Member

    Joined:
    Dec 12, 2015
    Messages:
    1,199
    Likes Received:
    358
    Updated first post, link to Firmata library issue
     
  11. modjo

    modjo Active Member

    Joined:
    Sep 29, 2014
    Messages:
    407
    Likes Received:
    125
    @waltervl , can you add this issue (see also here) about CAN bus and M4 core please ?
     
  12. waltervl

    waltervl Well-Known Member

    Joined:
    Dec 12, 2015
    Messages:
    1,199
    Likes Received:
    358
    Alhtough not completely related (supposed for some reason Arduino SPI is blocking CAN) I added it as a related issue.
     
    Last edited: Apr 27, 2017
  13. modjo

    modjo Active Member

    Joined:
    Sep 29, 2014
    Messages:
    407
    Likes Received:
    125
    Thanks Waltervl, but can you so kind and point me where this problem is related (Arduino Serial0 is blocking CAN) ?
     
  14. waltervl

    waltervl Well-Known Member

    Joined:
    Dec 12, 2015
    Messages:
    1,199
    Likes Received:
    358
    Oops, I mixed up UART5 (=Serial0) and ECSPI5, I modified the description. In your issue you suspect ECSPI5 to be the source of your problems. ECSPI5 is by default assigned to the M4.
     
  15. waltervl

    waltervl Well-Known Member

    Joined:
    Dec 12, 2015
    Messages:
    1,199
    Likes Received:
    358
    @Laura Just bump this for you so you are also aware of all these issues....
     
    Laura likes this.

Share This Page