Linux changes BIOS time.

Discussion in 'UDOO X86' started by bodgyuk, May 20, 2017.

  1. bodgyuk

    bodgyuk New Member

    Joined:
    Apr 26, 2017
    Messages:
    26
    Likes Received:
    2
    I have installed Windows 10 and Linux Mint. Linux Mint is set up for my time zone as is Windows.

    If I boot into Mint, the time is correct, but if I 'restart' in Linux and then select Windows 10 as my OS, the time becomes -12 hours relative to my local time.

    I have had a similar problem when I had a USB bootable copy of Android to run on my desktop PC and was told that it is just one of those things.

    Is there a setting in Linux or the Mint distribution that I can tinker with to prevent this annoyance?
     
  2. Kilrah

    Kilrah Member

    Joined:
    Apr 20, 2017
    Messages:
    31
    Likes Received:
    16
    ImLagging, Markus Laire and Maurice like this.
  3. Markus Laire

    Markus Laire Active Member

    Joined:
    Mar 9, 2017
    Messages:
    177
    Likes Received:
    75
    Alternatively you can also make Linux Mint save time as local time by adding line "UTC=no" (without quotes) to file /etc/default/rcS - discussion on Linux Mint forum.

    EDIT: At end of that discussion it is mentioned that in newer Linux Mint versions you should just use command "timedatectl set-local-rtc 1" instead.
     
    Alexander Chang and ImLagging like this.

Share This Page