Linux xfce (debian jessie) - blank screen

Discussion in 'UDOO X86' started by rallodi, Apr 22, 2017.

  1. rallodi

    rallodi New Member

    Apr 22, 2017
    Likes Received:

    I am typing this after some hours of reseach in forums and google :-(

    I have received my udoo x86.
    I downloaded the xfce installation image from debian
    I created my usb bootable stick and installed debian in the eMMC (32G)

    The system boots (grub, login ...) but as son as the X are started, the screen goes blank.
    I can login using the net, after loading the non-free ethernet "fw"
    If I boot in text mode, after executing "systemctl set-default", I can use the screen.

    I have tried my HDMI TV and a computer screen with the same result.

    The xorg logs read:

    [ 263.242] (II) VESA(0): Total Memory: 479 64KB banks (30656kB)
    [ 263.242] (II) VESA(0): <default monitor>: Using hsync range of 26.00-81.00 kHz
    [ 263.242] (II) VESA(0): <default monitor>: Using vrefresh range of 24.00-75.00 Hz
    [ 263.242] (II) VESA(0): <default monitor>: Using maximum pixel clock of 235.00 MHz
    [ 263.242] (WW) VESA(0): Unable to estimate virtual size
    [ 263.251] (--) VESA(0): Virtual size is 1920x1200 (pitch 1920)
    [ 263.251] (**) VESA(0): *Built-in mode "1920x1080"
    [ 263.251] (**) VESA(0): *Built-in mode "1600x1200"
    [ 263.251] (**) VESA(0): *Built-in mode "1280x1024"
    [ 263.251] (**) VESA(0): *Built-in mode "1024x768"
    [ 263.251] (**) VESA(0): *Built-in mode "800x600"
    [ 263.251] (**) VESA(0): *Built-in mode "640x480"
    [ 263.251] (==) VESA(0): DPI set to (96, 96)
    [ 263.251] (**) VESA(0): Using "Shadow Framebuffer"
    [ 263.251] (II) Loading sub module "shadow"
    [ 263.251] (II) LoadModule: "shadow"
    [ 263.251] (II) Loading /usr/lib/xorg/modules/
    [ 263.269] (II) Module shadow: vendor="X.Org Foundation"
    [ 263.269] compiled for 1.16.4, module version = 1.1.0
    [ 263.269] ABI class: X.Org ANSI C Emulation, version 0.4
    [ 263.269] (II) Loading sub module "fb"
    [ 263.269] (II) LoadModule: "fb"
    [ 263.270] (II) Loading /usr/lib/xorg/modules/
    [ 263.272] (II) Module fb: vendor="X.Org Foundation"
    [ 263.273] compiled for 1.16.4, module version = 1.0.0
    [ 263.273] ABI class: X.Org ANSI C Emulation, version 0.4
    [ 263.273] (==) Depth 24 pixmap format is 32 bpp
    [ 263.273] (II) Loading sub module "int10"
    [ 263.273] (II) LoadModule: "int10"
    [ 263.273] (II) Loading /usr/lib/xorg/modules/
    [ 263.273] (II) Module int10: vendor="X.Org Foundation"
    [ 263.273] compiled for 1.16.4, module version = 1.0.0
    [ 263.273] ABI class: X.Org Video Driver, version 18.0
    [ 263.273] (II) VESA(0): initializing int10
    [ 263.273] (II) VESA(0): Bad V_BIOS checksum
    [ 263.273] (II) VESA(0): Primary V_BIOS segment is: 0xc000
    [ 263.275] (II) VESA(0): VESA BIOS detected
    [ 263.275] (II) VESA(0): VESA VBE Version 3.0
    [ 263.275] (II) VESA(0): VESA VBE Total Mem: 30656 kB
    [ 263.275] (II) VESA(0): VESA VBE OEM: Intel(R) CHV Mobile/Desktop Graphics Chipset Accelerated VGA BIOS
    [ 263.275] (II) VESA(0): VESA VBE OEM Software Rev: 1.0
    [ 263.275] (II) VESA(0): VESA VBE OEM Vendor: Intel Corporation
    [ 263.275] (II) VESA(0): VESA VBE OEM Product: Intel(R) CHV Mobile/Desktop Graphics Controller
    [ 263.275] (II) VESA(0): VESA VBE OEM Product Rev: Hardware Version 0.0
    [ 263.275] (II) VESA(0): virtual address = 0x7f53346bd000,
    physical address = 0x80000000, size = 31391744
    Does anyone knows what is happening and how to solve it ?

    Thanks in advance


    Last edited: Apr 22, 2017
  2. LDighera

    LDighera UDOOer

    Jan 13, 2014
    Likes Received:

    I'm researching the Debian X11 issue on the Udoo X86 eMCC also: I'm also seeing random bright streaks and inverse video on the text-based console tty. I wonder what sort of reports the Debian team is receiving about the new Udoo hardware.

    Today my m.2 256GB SSD arrived, and I didn't see any issues at all with Win10Pro.

    I'm impressed with the responsiveness of Debian on the Udoo X86 platform. It will be interesting to see how snappy it with X11. Even Win10 is quick enough for impatient me, despite several programs open simultaneously.

    I'm hoping to run DX Lab under Windows to control an IC-7300 transceiver that is the heart of the solar-powered portable radio station I'm constructing. I'm particularly attracted to the new X86 platform for its low power requirement, and the ability to run Windows programs natively.
    Laura likes this.
  3. Laura

    Laura UDOOer

    Apr 22, 2016
    Likes Received:
    Excellent! Would love to follow your progress with your radio station project.
    UDOO has a Hackster page to help users learn from community projects and share new ones. Here's the page for the UDOO X86
  4. rallodi

    rallodi New Member

    Apr 22, 2017
    Likes Received:
    I have found that "Xorg --configure" does not work ....

    root@udoo:~# Xorg -configure

    X.Org X Server 1.16.4
    Release Date: 2014-12-20
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 3.16.0-4-amd64 x86_64 Debian
    Current Operating System: Linux udoo 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1+deb8u2 (2017-03-07) x86_64
    Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.16.0-4-amd64 root=UUID=c81ecc45-9fd9-4699-bf97-041230f14af9 ro vga=895 quiet
    Build Date: 11 February 2015 12:32:02AM
    xorg-server 2:1.16.4-1 (
    Current version of pixman: 0.32.6
    Before reporting problems, check
    to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Sat Apr 22 09:20:54 2017
    List of video drivers:
    (++) Using config file: "/root/"
    (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    Number of created screens does not match number of detected devices.
    Configuration failed.
    (EE) Server terminated with error (2). Closing log file.​
    Last edited: Apr 22, 2017
  5. LDighera

    LDighera UDOOer

    Jan 13, 2014
    Likes Received:
    Thank you for your interest in my intent to integrate the Udoo X86 into the solar-powered portable radio station, Laura.
    I've been designing, constructing, and testing for about a year, and now finalized selection of the most suitable components. I'm using LiFePO4 battery chemistry for it's light weight and high energy density. Unlike most other chemistries, LiFePO4 cells have an almost flat discharge curve. That means that during discharge the battery terminal voltage remains virtually constant until ~80% State Of Discharge. That makes it difficult to gauge the battery's SOC. But, after lengthy research and testing, it's all integrated and functioning remarkably well now.

    Constructing the 6-band, light-weight, two-element, directional antenna prototype proved its utility and performance, with one exception. The materials for a more robust coaxial feed-line arrived yesterday, so I've got my work cut out for the next few days.

    The entire 500 Watt HF/VHF portable station will be fitted into a 16" X 16" X 24" DeWALT plastic, rolling toolbox and two 4' X 1' cylindrical canvas bags; the solar panel is 24 X 48. Ideally, a 10.1" (or larger) LCD touch display for the Udoo X86 will be my next research project. :) Of course, the little computer will have to be shielded against EMI, I'm hoping Mindaugas Palubinskas ( will begin fabricating cases for the Udoo X86 like the very professional one he did for the Quad:

    I loaded DX Lab on the Udoo X86 today, and it runs fine so far. It's exciting to see this phase of the project progressing nicely. The Udoo hardware is snappy, low power, and the 4GB RAM appears adequate to support lots of open windows. Cool.

    Thank you for the suggestion. I do plan on writing about it. I'll probably put the report on a web page as progress proceeds. When complete, I'll submit it to Hackster.

    Best regards,
    Larry, WB6BBB
    Laura likes this.

Share This Page