Random freeze and restart

Discussion in 'UDOO X86' started by SvqD, Mar 5, 2019.

  1. SvqD

    SvqD UDOOer

    Joined:
    Jun 19, 2017
    Messages:
    28
    Likes Received:
    5
    Hi

    I have serious problem with my udoo, it started freezing up and random restarting.

    I think this started sometime around christmas time 2018, i was messing around with a few arduino scripts and i think the restart/freezes started after that, but i'm not sure.

    What i've tried:
    • unplugged the battery for a while to reset the bios to default.
    • complete format of the ssd and reinstalled Windows
    • update to the latest firmware
    Even after this it still freezes or restarts from time to time, before this i could run it for months straight without any problems.

    I'm kinda clueless what the problem is at this point, any ideas?

    As i'm writing this i'm running a CPU stress test with core temps around 50-53C, stabile so far, next thing would be a ram test.

    My setup:
    Device: Udoo x86 Ultra
    OS: Windows 10 Enterprise 64bit installed on a 250gb m.2 ssd
    Firmware: v1.06
     
  2. SvqD

    SvqD UDOOer

    Joined:
    Jun 19, 2017
    Messages:
    28
    Likes Received:
    5
    Update: I installed the Transcend SSD Scope tool, no indication of anything wrong with my SSD
    CPU stress test still running without any problems, small increase in temps 50-55C.
     
  3. SvqD

    SvqD UDOOer

    Joined:
    Jun 19, 2017
    Messages:
    28
    Likes Received:
    5
    After almost 24 hours seems like its not the CPU, gonna do a ram test.
     
  4. Snakebyte

    Snakebyte Member

    Joined:
    Mar 19, 2018
    Messages:
    90
    Likes Received:
    9
    The Udoo board will reboot when it gets a "triple fault," to use VirtualBox terms. An exception while handling an exception can cause this.
     
  5. SvqD

    SvqD UDOOer

    Joined:
    Jun 19, 2017
    Messages:
    28
    Likes Received:
    5
    Could this be because of a bad arduino script?
     
  6. Snakebyte

    Snakebyte Member

    Joined:
    Mar 19, 2018
    Messages:
    90
    Likes Received:
    9
    I don't know specifically, but you could intentionally write a bad Arduino script and see if induces the behavior you are seeing. Division by zero and reading/writing to 0x0 are always good for breaking things.
     
  7. SvqD

    SvqD UDOOer

    Joined:
    Jun 19, 2017
    Messages:
    28
    Likes Received:
    5
    Just finished 2 runs in memtest, no errors, gonna focus on arduino if i can replicate the error somehow.
     
  8. waltervl

    waltervl UDOOer

    Joined:
    Dec 12, 2015
    Messages:
    2,312
    Likes Received:
    580
  9. SvqD

    SvqD UDOOer

    Joined:
    Jun 19, 2017
    Messages:
    28
    Likes Received:
    5
    I actually just put the "Power On Intel Curie" function to Disabled in the BIOS, as i understand that should disable the arduino, and before that i uploaded a empty script.

    Still get random reboots and freezes.
     
  10. Snakebyte

    Snakebyte Member

    Joined:
    Mar 19, 2018
    Messages:
    90
    Likes Received:
    9
    Have you tried running an external debugger to the serial port?
     
  11. SvqD

    SvqD UDOOer

    Joined:
    Jun 19, 2017
    Messages:
    28
    Likes Received:
    5
    Unfortunately i don't have one, or i would have.

    Currently i'm testing an older firmware, 1.03, that is the one before i updated to 1.05, and then 1.06, i had most luck with that one.

    If i get freeze or reboots with that, then it must be a faulty board or maybe the PSU.
     
  12. waltervl

    waltervl UDOOer

    Joined:
    Dec 12, 2015
    Messages:
    2,312
    Likes Received:
    580
  13. SvqD

    SvqD UDOOer

    Joined:
    Jun 19, 2017
    Messages:
    28
    Likes Received:
    5
  14. SvqD

    SvqD UDOOer

    Joined:
    Jun 19, 2017
    Messages:
    28
    Likes Received:
    5
    When I logged on this morning the device was frozen again, at this point I have no clue what it can be.
    Everything is running default, clean windows installation and temps are fine, nothing connected to the Arduino.

    The only thing I can try now is switching out the PSU.
     
  15. SvqD

    SvqD UDOOer

    Joined:
    Jun 19, 2017
    Messages:
    28
    Likes Received:
    5
    doing some testing with the Watchdog disabled.
     
  16. SvqD

    SvqD UDOOer

    Joined:
    Jun 19, 2017
    Messages:
    28
    Likes Received:
    5
    TCO watchdog disabled and EC Watchdog disabled, still freeze.

    running on a new PSU now, lets see if that works.
     
  17. waltervl

    waltervl UDOOer

    Joined:
    Dec 12, 2015
    Messages:
    2,312
    Likes Received:
    580
    fingers crossed...
     
  18. SvqD

    SvqD UDOOer

    Joined:
    Jun 19, 2017
    Messages:
    28
    Likes Received:
    5
    nope.... it died again, i don't know at this point, i did notice a pattern, it seems to happen every 40-48 hours.
     
  19. Snakebyte

    Snakebyte Member

    Joined:
    Mar 19, 2018
    Messages:
    90
    Likes Received:
    9
    Can you nail it down to a specific interval? When I was porting an rtl8139/8169 ethernet driver for the Udoo to the unsupported OS I am using, I found the driver died after ten minutes. It turns out that a timer in the driver was attempting to access a statistics register on the ethernet card that was not present. The functionality had been removed for the rtl8111 chip. Being able to distinctly identify a fixed interval could help isolate the problem.
     
  20. SvqD

    SvqD UDOOer

    Joined:
    Jun 19, 2017
    Messages:
    28
    Likes Received:
    5
    I'll see what i can do, if my theory holds, then it will freeze again march 15th
     

Share This Page