Ubuntu UHD (aka 4k) @ 60Hz

Discussion in 'UDOO BOLT' started by zzarr, Jun 5, 2019.

  1. zzarr

    zzarr New Member

    Joined:
    Jun 5, 2019
    Messages:
    4
    Likes Received:
    1
    Hello!

    I can't set the resolution and framerate to 3840x2160@60 only 3840x2160@30 (over HDMI).
    I have installed Ubuntu 19.04, but I could install 18.04 if needed.
    I tried to add and activate 3840x2160@60 with the help of xrandr, but that did not work.
    My HDMI cable is about 2m in length and flat, could it be the problem?

    Best Regards
    / Rasmus
     
  2. waltervl

    waltervl UDOOer

    Joined:
    Dec 12, 2015
    Messages:
    2,077
    Likes Received:
    529
    Is your cable a HDMI 2.0 Cable?
    Is your monitor supporting 60Hz? Perhaps there is a setting.
    What monitor do you use?
     
    evaloverde likes this.
  3. zzarr

    zzarr New Member

    Joined:
    Jun 5, 2019
    Messages:
    4
    Likes Received:
    1
    Hello!

    The Cable is rated for 3840x2160@60Hz (I have tested with 2 cables from different vendors).

    The display can handle 3840x2160@60Hz according to the specification.

    So it's a problem with the driver (must be).

    Best Regards
    / Rasmus
     
  4. waltervl

    waltervl UDOOer

    Joined:
    Dec 12, 2015
    Messages:
    2,077
    Likes Received:
    529
    What monitor do you have? Sometimes monitors require extra settings in order to enable 60Hz
     
    evaloverde likes this.
  5. zzarr

    zzarr New Member

    Joined:
    Jun 5, 2019
    Messages:
    4
    Likes Received:
    1
    Hello!

    I have a Swedx 49" UHD-4K monitor. (Note: it's not a TV)

    I will here with Swedx if there's a setting (I can't find one).

    I searched for settings both in BIOS on the Bolt and in the displays settings.
    I'm guessing it have nothing to do with CEC? (and ARC is only for sound I think.)

    Best Regards
    / Rasmus
     
  6. zzarr

    zzarr New Member

    Joined:
    Jun 5, 2019
    Messages:
    4
    Likes Received:
    1
    Hello again!

    I got a response from the vendor of the display, it was a setting, EDID, when I selected 2.0 Ubuntu defaulted to 60Hz directly.

    Best Regards
    / Rasmus
     
    waltervl likes this.
  7. evaloverde

    evaloverde Administrator Staff Member

    Joined:
    Apr 29, 2019
    Messages:
    88
    Likes Received:
    21
    Great! Glad the issue was a non-issue
     

Share This Page