Udoo Neo Extended monitor mode issue

Discussion in 'Troubleshooting' started by Narzhan, Jan 22, 2016.

  1. Narzhan

    Narzhan New Member

    Dec 8, 2015
    Likes Received:
    I'd like to build a security device which would serve as demonstration and learning tool for my students. The goal of this device would be to display the behaviour of wireless networks and familiarize students with such things as wireless transmissions, client-ap associations etc.. Which brings me to the core of my problem:in order to get these information I need to setup a monitor mode interface to passively get the information I need for the some specified functions(from wifi management frames). However when I create the interface all I get are beacon and probe response frames from AP. I used my two python scripts which use raw sockets and tshark and tcpdump each of those tools only get beacons and probe requests. I tried the same commands at my linux latop and everything worked nice and easy I have tested it on probe requests. Has anyone used Udoo neo in similar way and could help me fix the problem?

    Used commands:
    iw phy phy0 interface add mon0 type monitor
    rfkill unblock
    ifconfig mon0 up
    tcpdump -i mon0 -e -s 256 type mgt subtype probe-req
    tshark -i mon0 subtype probereq

Share This Page