Udoo X86 Advanced Plus with new 32U4

Discussion in 'UDOO X86' started by Stephen Morgan, Sep 17, 2019.

  1. Stephen Morgan

    Stephen Morgan UDOOer

    Joined:
    Oct 13, 2018
    Messages:
    5
    Likes Received:
    0
    Just got a batch of these new boards, (around 50) and I see the 101 was removed and replaced with the 32U4. Wonderful Improvement!!! Anyway, I was playing with a fresh os install (Ubuntu 18.04.3) with all the latest patches, Fresh Install of Arduino 1.8.10. I added the local user to the dialout group and tried to upload the Blink sketch. I got an error half way through the process and now the 32U4 will not connect via the virtual serial port. The TX light just comes on solid. Pressing the Master Reset will cause the LED to pulse for a while and then back to the TX light stuck on and no virtual serial port. Did I kill the boot loader?
     
  2. waltervl

    waltervl UDOOer

    Joined:
    Dec 12, 2015
    Messages:
    2,312
    Likes Received:
    580
    Did you follow all the instructions of the known issue section of https://www.udoo.org/docs-x86II/Ard...4)/Getting_Started_with_Arduino_Leonardo.html

    Also did you folow the following procedure from https://www.arduino.cc/en/Guide/ArduinoLeonardoMicro#toc12 as mentioned in that same Udoo X86II doc page.
     
  3. Stephen Morgan

    Stephen Morgan UDOOer

    Joined:
    Oct 13, 2018
    Messages:
    5
    Likes Received:
    0
    That Fixed the issue!! Thanks for the help.

    Did the following again, the second script seems to have helped, by disabling the modem manager. It did require me pressing the Master Reset during the upload process the first time to get the firmware to load.

    sudo ./install.sh
    ./arduino-linux-setup.sh $USER

    Thanks again for your help!!

    I do have another follow up questing:
    On the previous version of the Udoo, with the 101, We had issues with a sketch running on the board failing to communicate via the serial port from time to time, the 101 would reset, the USB device would disappear. This was happening enough that we decided to not use the onboard 101, due to reliability issues. I am now wondering if the Modem Manager was getting in the way.

    The application was a piano keyboard with 16 switches connected to the IO pins on the 101, these needed to be de-bounced and passed onto the ubuntu OS as USB/Serial Messages in real time triggering the Udoo to play piano sounds via the sound card. We could never get this to work reliably. We would see in the logs were the serial port/USB would disappear at random times.
     
  4. waltervl

    waltervl UDOOer

    Joined:
    Dec 12, 2015
    Messages:
    2,312
    Likes Received:
    580
    I do not think oit ios the modem manager but the Arduino 101 has an issue with USB ( https://www.udoo.org/docs-x86/Arduino_101_(Intel_Curie)/Curie_Reset_on_PowerON.html ) altough this is something different. Perhaps your implementation of serial communication to Braswell had a bug. I have seen a lot of issues on this topic with Udoo boards.
     

Share This Page