UDOO x86 No Display on Reset (Won't Start)

Discussion in 'UDOO X86' started by mwshafer, Oct 6, 2022.

  1. mwshafer

    mwshafer UDOOer

    Oct 6, 2022
    Likes Received:
    We have an UDOO x86 Ultra (Version 1) that was recently working. In the process of attempting to install a new OS (Ubuntu) for a new project from a USB stick, the board seems to have stopped working. (Note that we have successfully done this install previously on a different UDOO board). Part of the way through the install the system hung up. Now when we try to start it, we just get a black screen. The green LED is illuminated. Here is what we have tried, based on other forum suggestions, in order to try to bring it back to life (we'd be happy with a BIOS menu at this point):

    1. Removing the microSD card and restarting
    2. Doing a factory reset by removing power and the battery, waiting, and then restarting
    3. Holding down the reset button on startup in case the Arduino is resetting the board
    4. Tried both HDMI and Display port monitor connections

    I will say that a USB 3.0 was plugged into the board when we originally attempted to reinstall the OS. That cable ran to a monitor, into which our mouse and keyboard were plugged. I have since found this language on the UDOO documentation page:

    Do not use a NON-standard USB 3.0 peripheral. If you use a non-standard USB 3.0 peripheral with an external power plug, this could send back the power source to the UDOO X86 board with the risk of damage.

    This message scary but not really clear. Why would the USB send the power source back to the UDOO. What does that even mean. Also, I don't know what they mean by 'non-standard USB 3.0.' I'll note that we had used this same USB connection in the past without issue.

    I'd like to know if there is anything else we should try to bring this board back to life. This is the second UDOO that we've seen do something like this where it just seems to stop working, so figuring this out is pretty critical for us.

Share This Page