UDOO X86 Windows 10 64bit and Arduino IDE 1.8.2.0

Discussion in 'UDOO X86' started by Jetguy, Apr 10, 2017.

  1. Jetguy

    Jetguy Member

    Joined:
    Mar 28, 2017
    Messages:
    65
    Likes Received:
    59
    I ran into an issue with Windows 10 and the Arduino IDE 1.8.2.0 when trying to program the Intel Curie 101 just using the normal "Blink" example after loading the required Intel Curie 101 via the boards manager.

    Arduino: 1.8.2 (Windows Store 1.8.2.0) (Windows 10), Board: "Arduino/Genuino 101"
    fork/exec C:\Users\UDOO\Documents\ArduinoData\packages\Intel\tools\arc-elf32\1.6.9+1.0.1/bin/arc-elf32-g++.exe: An error in a system binary was detected. Try refreshing the PC to fix the problem.
    Error compiling for board Arduino/Genuino 101.
    This report would have more information with
    "Show verbose output during compilation"
    option enabled in File -> Preferences.

    Googling the error message, I'm not alone with this error, however, trying the workaround by setting the security setting per this thread did not resolve. https://github.com/01org/corelibs-arduino101/issues/309

    That said, the easier workaround was to just go browser based
    [​IMG]
    All Arduino and Genuino boards, including this one, work out-of-the-box on the Arduino Web Editor, no need to install anything.

    The Arduino Web Editor is hosted online, therefore it will always be up-to-date with the latest features and support for all boards. Follow this simple guide to start coding on the browser and upload your sketches onto your board.
     
  2. Jetguy

    Jetguy Member

    Joined:
    Mar 28, 2017
    Messages:
    65
    Likes Received:
    59
    Just a note, I was able to load sketches no issues at all just using the browser based version. This is not an UDOO X86 specific error, more like a Windows 10 and Arduino local IDE error. The point of posting was just a heads up for those who run into the same error and if a better workaround comes up that hopefully can be resolved soon.
     
  3. Andrea Rovai

    Andrea Rovai Well-Known Member

    Joined:
    Oct 27, 2014
    Messages:
    1,703
    Likes Received:
    240
    Hi @Jetguy,
    a colleague of mine has had the same problem but after a fresh install of Arduino IDE and Intel Curie from board manager everything was fine. Could you try and tell me if it is the same for you?
     
  4. Jetguy

    Jetguy Member

    Joined:
    Mar 28, 2017
    Messages:
    65
    Likes Received:
    59
    It appears a complete uninstall and reinstall allows Arduino local IDE to program. Honestly, I got no error messages during the install the first time, this seems rather off because it even validates the integrity during the install. Again, it's unfair to blame this on UDOO X86, this is more of a Win10 and Arduino not playing nicely kind of issue that anything to worry abut the board, but does affect us if you use this combination.
     
    Andrea Rovai likes this.
  5. Daniel Hrynczenko

    Daniel Hrynczenko New Member

    Joined:
    Apr 6, 2017
    Messages:
    6
    Likes Received:
    7
    I am having similar problems on Ubuntu 17.0.4 and haven't yet figured out why:

    when uploading blink
    board arduino 101, port ttyACM0 (the board itself is recognized by arduino env.)
    Starting download script...
    Flashing is taking longer than expected
    Try pressing MASTER_RESET button
    ERROR: Timed out waiting for Arduino 101 on /dev/ttyACM0
    ERROR: Timed out waiting for Arduino 101 on /dev/ttyACM0

    I can without problems connect another arduino through usb and program it, serial permissions seem right and I've tried using the Master Reset without any success so far, Tried to uninstall/reinstall but still get the same issue. The Arduino101 is recognized by the arduino-environment
    I'm having some issues with the Arduino web editor with certificates that I will try to resolve that to test if it might work that way
     
    tuxun likes this.
  6. bpr

    bpr New Member

    Joined:
    Nov 11, 2013
    Messages:
    10
    Likes Received:
    7
    I am able to get the Arduino IDE to program the onboard 101 by going to my arduino install directory (/opt/arduino-1.8.2) and starting the IDE with sudo ./arduino

    Edit: you can make an Arduino.desktop launcher file like below and put it in /usr/share/applications
    You will probably need to install gksu beforehand

    [Desktop Entry]
    Version=1.0
    Type=Application
    Terminal=false
    Icon[en_US]=/opt/arduino-1.8.2/lib/arduino_icon.ico
    Name[en_US]=Arduino
    Exec= gksudo -k -u root /opt/arduino-1.8.2/arduino
    Name=Arduino
     
    Last edited: Apr 19, 2017
  7. TheCluster

    TheCluster New Member

    Joined:
    Apr 18, 2017
    Messages:
    1
    Likes Received:
    4
    Fix for Ubuntu:

    Code:
    sudo usermod -a -G dialout $USER
    wget https://github.com/01org/intel-arduino-tools/raw/linux64/scripts/create_dfu_udev_rule
    chmod +x create_dfu_udev_rule
    sudo ./create_dfu_udev_rule
    rm create_dfu_udev_rule
    
    other ide settings:

    board - "Arduino/Genuino 101"
    port - "/dev/ttyACM0"
    programmer - "USBasp"
     

    Attached Files:

    Last edited: Apr 19, 2017
  8. Daniel Hrynczenko

    Daniel Hrynczenko New Member

    Joined:
    Apr 6, 2017
    Messages:
    6
    Likes Received:
    7
    That resolved it :)
    reboot needed if someone else is looking up this solution

     
    tuxun likes this.
  9. sirrab

    sirrab UDOOer

    Joined:
    Jul 26, 2014
    Messages:
    256
    Likes Received:
    31
    Sure would be nice to know what is being done here.
     
  10. mkopack

    mkopack Member

    Joined:
    Jun 14, 2013
    Messages:
    451
    Likes Received:
    21
    I can't even get the Arduino editor to install properly on Ubuntu 16.04. Grrr. I run the install script and it seems like it's doing stuff and then it spits out a bunch of error messages about no vendor information provided. I never get an icon. I can run from the command line though and as long as I run using sudo I was able to select the proper port and upload (at least the first time, subsequent running of the IDE didn't show that option in the ports...) Need to try what you guys did above...
     
  11. Marc Scattolin

    Marc Scattolin New Member

    Joined:
    May 1, 2017
    Messages:
    1
    Likes Received:
    1
    This is a known issue. https://github.com/arduino/Arduino/issues/6116 . To solve it, change, in install.sh,
    "RESOURCE_NAME=cc.arduino.arduinoide" to "RESOURCE_NAME=arduino-arduinoide"
    Make sure to also change the period "." to a dash "-" between arduino and arduinoide and to not just remove the cc.
     
    Last edited: May 3, 2017
    waltervl likes this.
  12. tuxun

    tuxun Member

    Joined:
    Dec 20, 2013
    Messages:
    67
    Likes Received:
    12
    Code:
    Starting download script...
    Flashing is taking longer than expected
    Try pressing MASTER_RESET button
    ERROR: Timed out waiting for Arduino 101 on /dev/ttyACM0
    
    "USBasp programmer" checked, that's solved my problem too, thanks!
     
  13. fabio978

    fabio978 Member

    Joined:
    Jul 2, 2014
    Messages:
    51
    Likes Received:
    5
    This became an Ubuntu thread instead... The worse thing is that people looking for this solution in Ubuntu would never look for it on a Windows 10 topic...
     
  14. lucabelluccini

    lucabelluccini New Member

    Joined:
    May 2, 2017
    Messages:
    7
    Likes Received:
    3
    If you're facing issues on Ubuntu instead, you can try following this guide
     
  15. EBRAddict

    EBRAddict New Member

    Joined:
    Jun 18, 2017
    Messages:
    3
    Likes Received:
    1
    This worked perfectly, thanks.
     

Share This Page