UDOOBuntu 2 beta 3 for UDOO Quad released

Discussion in 'Linux Ubuntu' started by Francesco, Nov 9, 2015.

Thread Status:
Not open for further replies.
  1. Zeus

    Zeus New Member

    Joined:
    Oct 11, 2013
    Messages:
    6
    Likes Received:
    0
    Good to know that you guys are considering adding something back that was promised in the first place.
    Can you provide us with a timeline as to when these features can be expected in a build?
     
  2. Andrea Rovai

    Andrea Rovai Well-Known Member

    Joined:
    Oct 27, 2014
    Messages:
    1,703
    Likes Received:
    240
  3. Theflorianmaas

    Theflorianmaas UDOOer

    Joined:
    Dec 7, 2013
    Messages:
    22
    Likes Received:
    2
    Unfortunately with Uboobuntu 2 it doesn't work for me.
    I have created a microSD with the boot image, the sata driver with Udoobuntu 2, and changed the fstab on sata
    Following the procedure I get the boot hungs here:

    [ 1.963666] Waiting for root device /dev/sda2...

    Any suggestion?
    Thank you
    Franco
     
  4. sirrab

    sirrab UDOOer

    Joined:
    Jul 26, 2014
    Messages:
    258
    Likes Received:
    31
    What does that small boot image expand out to? When I "dd" it to a FAT32 partition, the partition gets corrupted. I have tried it on 2 Linux boxes, a iMac and a Windows machine.
     
  5. pdblood

    pdblood New Member

    Joined:
    Apr 7, 2014
    Messages:
    12
    Likes Received:
    0
    I get the same result as @Theflorianmaas. Could @Andrea Rovai or @Francesco post the output of "printenv" from the U-Boot serial terminal on the system where they are having success booting from sata with UDOObuntu2 RC1?
     
  6. vpeter

    vpeter Active Member

    Joined:
    Nov 29, 2014
    Messages:
    303
    Likes Received:
    62
    As per instructions you write it to start of sd card - and not to partition. And in this image is no partition only bootloader.
     
  7. sirrab

    sirrab UDOOer

    Joined:
    Jul 26, 2014
    Messages:
    258
    Likes Received:
    31
    So, has the Ubuntu beta image for UDOO Quad become merged with UDOO Neo?
     
  8. Andrea Rovai

    Andrea Rovai Well-Known Member

    Joined:
    Oct 27, 2014
    Messages:
    1,703
    Likes Received:
    240
    Dear pdblood, I feel very sorry for being so late with this answer. Anyway, we recently passed to UDOObuntu 2 RC2, you may be interested to check it out before I answer your question about UDOObuntu 2 RC1
     
  9. pdblood

    pdblood New Member

    Joined:
    Apr 7, 2014
    Messages:
    12
    Likes Received:
    0
    Hi Andrea, I just tried with the new image and get the same result as before. Has someone from the Udoo do team done this successfully with UDOObuntu 2 RC1/2? If so, could you post printenv from uboot and the output from the boot sequence?
     
  10. sirrab

    sirrab UDOOer

    Joined:
    Jul 26, 2014
    Messages:
    258
    Likes Received:
    31
  11. sirrab

    sirrab UDOOer

    Joined:
    Jul 26, 2014
    Messages:
    258
    Likes Received:
    31
    BTW, the latest beta version works with an HDMI monitor. There is no time zone utility. Was able to set my time zone with the terminal, though. Dragging windows with the mouse is still slow and jerky. Network utility works very well! Able to use WI-Fi or wired, and it switches between either if you make changes. (Pull the Ethernet cable out or plug it in) Yay! Release sees my SSD is connected. Software update utility works! WOW! Somebody needs to go through ALL the documentation on the web, to clean up missing pages, just plain wrong info, etc. Still playing around with the new release. I'm happier! Just need the lagging window and no booting from SATA issues fixed.
     
  12. sirrab

    sirrab UDOOer

    Joined:
    Jul 26, 2014
    Messages:
    258
    Likes Received:
    31
    This happens for me as well.
     
  13. sirrab

    sirrab UDOOer

    Joined:
    Jul 26, 2014
    Messages:
    258
    Likes Received:
    31
    How does the image written to the SSD get expanded out, like the it does on the uSD card?
     
  14. vpeter

    vpeter Active Member

    Joined:
    Nov 29, 2014
    Messages:
    303
    Likes Received:
    62
    Seems this u-boot doesn't find any sata device:
    Code:
    U-Boot SPL 2015.10-00062-g8af36f3 (Mar 08 2016 - 16:53:02)
    U-Boot 2015.10-00062-g8af36f3 (Mar 08 2016 - 16:53:02 +0100)
    
    CPU:  Freescale i.MX6Q rev1.2 at 792 MHz
    Reset cause: POR
    Board: UDOO Quad
    DRAM:  1 GiB
    MMC:  FSL_SDHC: 0
    *** Warning - bad CRC, using default environment
    
    No panel detected: default to HDMI
    Display: HDMI (1024x768)
    In:  serial
    Out:  serial
    Err:  serial
    Net:  using phy at 6
    FEC [PRIME]
    Hit any key to stop autoboot:  0
    switch to partitions #0, OK
    mmc0 is current device
    AHCI 0001.0300 32 slots 1 ports 3 Gbps 0x1 impl SATA mode
    flags: ncq stag pm led clo only pmp pio slum part
    No port device detected!
    ** Bad device size - sata 0 **
    Device Tree: dts/imx6q-udoo-hdmi.dtb
    ** Bad device size - sata 0 **
    Booting from net ...
    BOOTP broadcast 1
    DHCP client bound to address 10.0.0.12 (3 ms)
    Using FEC device
    TFTP from server 10.0.0.1; our IP address is 10.0.0.12
    Filename 'zImage'.
    Load address: 0x12000000
    Loading:
    
    Seems sata init doesn't find anything:
    Code:
    => sata init
    AHCI 0001.0300 32 slots 1 ports 3 Gbps 0x1 impl SATA mode
    flags: ncq stag pm led clo only pmp pio slum part
    No port device detected!
    
    =>
     
  15. Francesco

    Francesco Active Member

    Joined:
    Jun 23, 2015
    Messages:
    220
    Likes Received:
    110
    It is quite hard for me to track several separate issues on a single thread. Please, open a new thread for new specific problems.
    SATA boot and HDMI video should work on the last beta, If you still have troubles please open a separate topic. Thank you!
     
  16. sirrab

    sirrab UDOOer

    Joined:
    Jul 26, 2014
    Messages:
    258
    Likes Received:
    31
    It would be nice if the instructions to make SATA boot work, worked.
     
  17. Francesco

    Francesco Active Member

    Joined:
    Jun 23, 2015
    Messages:
    220
    Likes Received:
    110
    There was a SCSI component built as module instead of built-in. If you rebuild kernel from sources, it will work.
    I have prepared a tar.gz with the rebuilt kernel for simplicity: https://drive.google.com/open?id=0B400VKg9Vc0rX0FaSklQQ0xsU2M
    If you want to auto expand rootfs on SATA, you also need to patch /etc/init.d/firstrun

    Both fixes will be integrated on final UDOObuntu 2
    I'm closing this topic, since it was related to beta3. If you have any other question, please open a separate thread. Thank you!
     
Thread Status:
Not open for further replies.

Share This Page