Unlocking CPU frequency to full 2.24GHz?

Discussion in 'UDOO X86' started by andyshinn, Nov 11, 2017.

  1. andyshinn

    andyshinn New Member

    Joined:
    Oct 15, 2017
    Messages:
    7
    Likes Received:
    3
    I'm trying to get the CPU frequency up to 2.24 Ghz on the Advanced board. I've got Ubuntu 16.04 installed along with cpufrequtils package. I also have custom active cooling on my boards (current CPU stress tests stay under about 51c so it seems like it could handle a higher frequency).

    I first tried setting the performance governor:
    Code:
    ubuntu@udoo1:~$ sudo cpufreq-set -r -g performance
    
    But no go:
    Code:
    ubuntu@udoo1:~$ sudo cpufreq-info
    cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
    Report errors and bugs to cpufreq@vger.kernel.org, please.
    analyzing CPU 0:
      driver: intel_pstate
      CPUs which run at the same hardware frequency: 0
      CPUs which need to have their frequency coordinated by software: 0
      maximum transition latency: 0.97 ms.
      hardware limits: 480 MHz - 2.24 GHz
      available cpufreq governors: performance, powersave
      current policy: frequency should be within 480 MHz and 1.79 GHz.
                      The governor "performance" may decide which speed to use
                      within this range.
      current CPU frequency is 1.76 GHz (asserted by call to hardware).
    
    Setting the speed manually doesn't seem to affect it either:
    Code:
    ubuntu@udoo1:~$ sudo cpufreq-set -r -u 2.24Ghz
    ubuntu@udoo1:~$ sudo cpufreq-info
    cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
    Report errors and bugs to cpufreq@vger.kernel.org, please.
    analyzing CPU 0:
      driver: intel_pstate
      CPUs which run at the same hardware frequency: 0
      CPUs which need to have their frequency coordinated by software: 0
      maximum transition latency: 0.97 ms.
      hardware limits: 480 MHz - 2.24 GHz
      available cpufreq governors: performance, powersave
      current policy: frequency should be within 480 MHz and 1.79 GHz.
                      The governor "performance" may decide which speed to use
                      within this range.
      current CPU frequency is 1.76 GHz (asserted by call to hardware).
    
    I also tried disabling intel_pstate:
    Code:
    ubuntu@udoo1:~$ cat /proc/cmdline
    BOOT_IMAGE=/vmlinuz-4.10.0-38-generic root=/dev/mapper/udoo1--vg-root ro intel_pstate=disable quiet splash vt.handoff=7
    
    But it results in even lower default frequencies:
    Code:
    ubuntu@udoo1:~$ sudo cpufreq-info
    cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
    Report errors and bugs to cpufreq@vger.kernel.org, please.
    analyzing CPU 0:
      driver: acpi-cpufreq
      CPUs which run at the same hardware frequency: 0
      CPUs which need to have their frequency coordinated by software: 0
      maximum transition latency: 10.0 us.
      hardware limits: 480 MHz - 1.60 GHz
      available frequency steps: 1.60 GHz, 1.60 GHz, 1.52 GHz, 1.44 GHz, 1.36 GHz, 1.28 GHz, 1.20 GHz, 1.12 GHz, 1.04 GHz, 960 MHz, 880 MHz, 800 MHz, 720 MHz, 640 MHz, 560 MHz, 480 MHz
      available cpufreq governors: conservative, ondemand, userspace, powersave, performance, schedutil
      current policy: frequency should be within 480 MHz and 1.28 GHz.
                      The governor "ondemand" may decide which speed to use
                      within this range.
      current CPU frequency is 1.28 GHz (asserted by call to hardware).
      cpufreq stats: 1.60 GHz:4.57%, 1.60 GHz:0.00%, 1.52 GHz:0.00%, 1.44 GHz:0.00%, 1.36 GHz:0.00%, 1.28 GHz:47.17%, 1.20 GHz:0.03%, 1.12 GHz:0.04%, 1.04 GHz:0.03%, 960 MHz:0.08%, 880 MHz:0.80%, 800 MHz:0.10%, 720 MHz:0.21%, 640 MHz:0.34%, 560 MHz:2.55%, 480 MHz:44.10%  (107)
    
    After some more digging I found the pstate sysfs settings. There seems to be a max scaling percentage locked at 80%:
    Code:
    ubuntu@udoo1:~$ echo 100 | sudo tee /sys/devices/system/cpu/intel_pstate/max_perf_pct
    100
    ubuntu@udoo1:~$ cat /sys/devices/system/cpu/intel_pstate/max_perf_pct 
    80
    
    So, is there a way to get Ubuntu running at full 2.24GHz clock?
     
    Last edited: Nov 11, 2017
  2. Markus Laire

    Markus Laire Active Member

    Joined:
    Mar 9, 2017
    Messages:
    225
    Likes Received:
    91
    This has been discussed before, and there doesn't seem to be any way to use full speed.

    For some reason e.g. Ubuntu and Debian limit speed to about 80% of maximum.
     
  3. ccs_hello

    ccs_hello UDOOer

    Joined:
    Apr 15, 2017
    Messages:
    479
    Likes Received:
    172
  4. andyshinn

    andyshinn New Member

    Joined:
    Oct 15, 2017
    Messages:
    7
    Likes Received:
    3
    Does that mean that it also runs at 1.76 GHz on other operating systems (such as Windows) as well? If it is actually locked to 1.76 on the CPU then why is it advertised as 2.24 GHz? Under what conditions can it reach 2.24 GHz?
     
  5. ccs_hello

    ccs_hello UDOOer

    Joined:
    Apr 15, 2017
    Messages:
    479
    Likes Received:
    172
    In all operating systems.
    2.24 is a marketing gimmick.
    Intel never disclosed exactly on what conditions will trigger the up-speed but we know it's very brief
    (so it won't kill the higher priced CPU tier) and it does want to "return to normal" ASAP.
    After all, ATOM family is extremely cheap (is there to compete with ARM)
    and supposed to be low heat generated (fanless is the ultimate goal) and low power consumption.

    For example, the latest ATOM gen upgrade, the server class and desktop class are essentially cancelled.
    Gap in between the low-tier high-grade and mid-tier low grade is getting too close.
    Volume pricing on ATOM can be very, very low (say less than $20 for the entire system SoC),
    while Pentium is about $40 and up
    and i3 is close to a 3-digit figure.
     
    LDighera likes this.
  6. itimpi

    itimpi UDOOer

    Joined:
    Oct 31, 2013
    Messages:
    122
    Likes Received:
    33
    I get the burst speed on Windows if running a CPU intensive process on my Ultra.
     

Share This Page