Use SPI with iMX6 and Linux

Discussion in 'General Programming Discussion' started by xCite, Feb 25, 2016.

  1. xCite

    xCite New Member

    Feb 25, 2016
    Likes Received:
    Hello all together,
    I'm new to UDOO, i just switched from a Raspberry PI 2 to a UDOO Quad a few weeks ago.

    My problem:
    I'm trying to use the SPI bus and i don't get it. I tried it with directly writing to the registers and followed exactly the Freescale manual for the iMX6. I checked all my steps several times and i thinkg I don't make a mistake. Is there any known issue with the manual? Maybe a wrong register address? I'm writing the registers according to the manual and I'm getting no errors, but there is no output at the according pins.
    I setup the CCM registers to gate the pll3 clock to the SPI controller. Then I initialize the ECSPI according the steps in the manual. After that I setup the IOMUXC to gate the SPI signals to the right pads. Now im trying to transfer data. I tried it with auto start SPI bursts and with manual start throughout the XCH bit in the ECSPI_CONREG.
    Maybe the problem is because of the CCM module, because I also tried to forward the pll3 clock to GPIO13 pad. Therefor I configured the CCM_CCOSR register and the IOMUXC_SW_MUX_CTL_PAD_GPIO19 register, but i got no output on the according pin.

    Does anyone got the ECSPI working with registers manipulation?

    Or is there a more easy solution to get it working with a linux driver?

    Would be awesome if anyone can help me!

    Best regards

Share This Page