'/usr/sbin/shutdown -h now' does not shutdown / halt

Discussion in 'UDOO BOLT' started by Richard Gomes, Dec 12, 2019.

  1. Richard Gomes

    Richard Gomes UDOOer

    Joined:
    Dec 11, 2019
    Messages:
    3
    Likes Received:
    2
    I'm using Debian 10.2 on an UDOO Bolt V8.

    $ uname -a
    Linux mercury 5.3.0-0.bpo.2-amd64 #1 SMP Debian 5.3.9-2~bpo10+1 (2019-11-13) x86_64 GNU/Linux

    Aparently, the command /usr/sbin/shutdown -h now is not sufficient for shutting down the system. The internal fan continues to spin, even after several minutes after the command was run. The power led is yellow. If I press the power button once again, does not matter if a short press or a very long press, the system starts once again. The only way to stop the fan after the command shutdown is disconnecting the power cord.

    I've upgraded the kernel and I've installed AMD GPU drivers from buster-backports according to this installation script: https://gist.github.com/frgomes/aa3a3e091ca12ab755b4a2633b3b3797

    Please let me know which sort of information you need from me in order to figure out what could be the issue.

    Any idea how to fix this problem?

    Thanks a lot,
     
  2. Zgembo

    Zgembo UDOOer

    Joined:
    Sep 21, 2019
    Messages:
    47
    Likes Received:
    25
    tried *poweroff* command?
     
  3. Richard Gomes

    Richard Gomes UDOOer

    Joined:
    Dec 11, 2019
    Messages:
    3
    Likes Received:
    2
    I've tried
    $ sudo shutdown --poweroff now
    and it works. The fan stops. Thanks for that! :)

    Interesting... I'm using Unix systems since 1985 and I don't remember of ever using option --poweroff. Maybe I've used before... but I don't remember. I've always used option "-h". The documentation of command shutdown says that "-h" is "Equivalent to --poweroff, overridden by --halt", which I interpret as just "equivalent to poweroff".

    Anyway... it works. Once again: thanks a lot :)
     
    nophead likes this.

Share This Page