Yocto + Qt5 + LVDS on i.MX6 (FSL Community BSP): Rendering and color depth

Discussion in 'Yocto' started by juliend, Jan 18, 2017.

  1. juliend

    juliend New Member

    Joined:
    Oct 14, 2016
    Messages:
    3
    Likes Received:
    0
    I've made my own yocto image for a Udoo neo board using graugans/meta-udoo, in eglfs mode (no X11 / Wayland), following this tutorial : http://wiki.wandboard.org/index.php/Building_Qt5_using_yocto_on_Wandboard
    Then I developped a simple QT5 application displayed on Udoo's 7" LVDS display.
    The rendering of my image is not correct. It seems to be displayed in R/G/B/A = 4/4/4/0 instead of 6/6/6/0.
    How can I specify this values before launchning my application ?
    Moreover, transparency is not correctely managed on LVDS (but works fine on my PC), could it be a matter with ALPHA value ?

    I launch my application by running this script :
    Application logs :

    Many thanks,
     
  2. modjo

    modjo Active Member

    Joined:
    Sep 29, 2014
    Messages:
    410
    Likes Received:
    125
    Hi i never had this problem, perhaps an issue with dts for lvds 7 ! If you use the official distribution udoobuntu (or the yocto image build with Graugans), did you have the same problem ?
     
  3. juliend

    juliend New Member

    Joined:
    Oct 14, 2016
    Messages:
    3
    Likes Received:
    0
  4. modjo

    modjo Active Member

    Joined:
    Sep 29, 2014
    Messages:
    410
    Likes Received:
    125
    Ok could you try with my build for neo here and let me know (it work fine for me with lvds7 ...)
    Otherwise, there are a beta version of udoobuntu (16.04 ) that have Qt5 natively here ...
     

Share This Page