Ubuntu 18.04 for UDOO Quad/Dual

Discussion in 'UDOO QUAD' started by Francesco, Sep 25, 2019.

  1. abektes

    abektes New Member

    Joined:
    May 30, 2014
    Messages:
    7
    Likes Received:
    0
    Thank you Evaloverde. Firstly, The wifi is not working and I don't see any prompt for password. Secondly, I don't see any browser and tried to install chromium-browser with apt install but I think that it is working but problem at rendering - I see black boxes. Which browser can I use with 18.04? Any ideas? Maybe I can get some help about these issues, thank you.
     
  2. Totalslaughter

    Totalslaughter New Member

    Joined:
    Oct 23, 2013
    Messages:
    3
    Likes Received:
    0
    So tried this a couple times flashing to microsd with win32disk for a quad. When trying to boot I get a quick black screen with UDOO logo for a second and then get no hdmi out signal ever again after that. Any ideas what might be causing this not to work / things to try? Thanks.
     
  3. evaloverde

    evaloverde Administrator Staff Member

    Joined:
    Apr 29, 2019
    Messages:
    204
    Likes Received:
    56
    Hello there. Unfortunately, Francesco doesn't work with us anymore, so we don't know if he'll update this version. It has to be considered a user made update
     
  4. abektes

    abektes New Member

    Joined:
    May 30, 2014
    Messages:
    7
    Likes Received:
    0
    So, it means that there is no support for UDOO Quad, right? How can we use this board in a secure way, can you guide us? Cheers,
     
  5. mert

    mert UDOOer

    Joined:
    Oct 20, 2013
    Messages:
    10
    Likes Received:
    0
    I was hopeful to find a more secure, updated kernel and OS base for UDOO QUAD but this is a bit frustrating. It came down to; "buy a couple good boards but forget about them in a few years and buy newer ones".

    Discouraging.

    Will we ever have a chance to get a good official distro like Francesco's?
     
  6. Maurizio Omissoni

    Maurizio Omissoni New Member

    Joined:
    Aug 2, 2020
    Messages:
    1
    Likes Received:
    0
    So old images, support must still be in siesta. Even the quad is old, i wanted to install kodi, but its not possible.
    this is the first ubuntu 18.04 that following steps does not work:

    sudo apt-get install software-properties-common
    sudo add-apt-repository ppa:team-xbmc/ppa
    sudo apt-get update
    sudo apt-get install kodi

    at the last step these errors come:

    The following packages have unmet dependencies:
    kodi : Depends: kodi-x11 (< 2:18.8+git20200728.1313-final-0bionic.1~) but it is not installable
    Depends: libshairplay0 but it is not installable
    Recommends: libvdpau1 but it is not going to be installed
    Recommends: i965-va-driver but it is not installable
    Recommends: libva2 but it is not going to be installed or
    libva1 but it is not installable
    Recommends: mesa-vdpau-drivers but it is not going to be installed
    Recommends: kodi-peripheral-joystick but it is not installable
    Recommends: kodi-inputstream-adaptive but it is not installable
    Recommends: kodi-inputstream-rtmp but it is not installable
    E: Unable to correct problems, you have held broken packages.

    So i can throu it away! pity
     
  7. Eric Jorgensen

    Eric Jorgensen New Member

    Joined:
    Nov 3, 2020
    Messages:
    1
    Likes Received:
    0
    I realize that I'm responding to a pretty old message, but though the x11 gui configuration for wifi clearly does not work, if you open an xterm and run nmtui-connect, the text mode configuration does work.

    It's probably better to run Armbian at this point, but the wifi doesn't appear to work in Armbian. At some point soon i will make a bug report for that on the armbian forums.
     
  8. jerichodee

    jerichodee UDOOer

    Joined:
    Jan 5, 2014
    Messages:
    19
    Likes Received:
    1
    The download links keep timing out for me. Is there a new mirror or download source that works 100%
     
  9. nieebel

    nieebel New Member

    Joined:
    Jan 23, 2021
    Messages:
    1
    Likes Received:
    0
    Hi guys, I would also love to get a newer Kodi on my UDOO Dual.

    Im currently super super happy with vpeter's libreelec 8.2!
    After "online updates", I was even able to get Docker running, but Kodi 17 is too old ro run the Netflix and Joyn plugin :(
    https://www.udoo.org/forum/threads/openelec-5-95-2.2421/page-3#post-46376

    What I tried sofar:
    1. udoobuntu 16/18 -> failed to get Kodi starting, too
    2. Android 6.0.1 from http://www.udoo.org/downloads/ with GApps pico -> I could install the Kodi 18 App directly from Aurora Store. But DRM is not working (Netflix/Joyn) and the performance is crap in comparison to libreelec 8.2.
    ERROR: AddOnLog: InputStream Adaptive: Unable to initialize media_drm
    ERROR: AddOnLog: InputStream Adaptive: OpenDRMSystem failed

    What I didn't tried sofar:
    3. igorpec's armbian (did somebody get Kodi working properly here with hardware acceleration?) https://www.udoo.org/forum/threads/ubuntu-bionic-and-debian-stretch.18041/
    4. use netflix/joyn via chromium with hardware acceleration: https://github.com/Freescale/chromium-imx (first get "widevine cdm"/libdrm from somewhere for imx6)
    5. try out secuflag's AOSP-6.0.1_r79/NPX BSP android_M6.0.1_2.1.0 from March 2017 https://www.udoo.org/forum/threads/8-mar-6dq-6sx-aospmod-mm-r-07.4701/
    6. try a even newer android from NXP/Freescale https://github.com/boundarydevices/linux-imx6/

    Let me know if you were successful with one or the other solution! :)
     

Share This Page