udoo-iot-cloud-client compatibility with Ubuntu 18.04

Discussion in 'UDOO IOT CLOUD' started by maxromanovsky, Oct 23, 2018.

  1. maxromanovsky

    maxromanovsky New Member

    Joined:
    Oct 23, 2018
    Messages:
    7
    Likes Received:
    1
    When will you make udoo-iot-cloud-client compatible with Ubuntu 18.04?
    Is it even supported / evolving?
     
  2. maxromanovsky

    maxromanovsky New Member

    Joined:
    Oct 23, 2018
    Messages:
    7
    Likes Received:
    1
    Mkay... Is anyone alive on the forum? :)
     
  3. waltervl

    waltervl Well-Known Member

    Joined:
    Dec 12, 2015
    Messages:
    1,885
    Likes Received:
    462
    Is it not working on 18.04? What is the problem?
     
  4. maxromanovsky

    maxromanovsky New Member

    Joined:
    Oct 23, 2018
    Messages:
    7
    Likes Received:
    1
    That's the problem, more or less:
    Code:
    Error: The module '/opt/udoo-iot-client/node_modules/bluetooth-hci-socket/bui
    Oct 22 00:21:50 udoo-x86 nodejs[11709]: was compiled against a different Node.js version using
    Oct 22 00:21:50 udoo-x86 nodejs[11709]: NODE_MODULE_VERSION 48. This version of Node.js requires
    Oct 22 00:21:50 udoo-x86 nodejs[11709]: NODE_MODULE_VERSION 57. Please try re-compiling or re-installing
    Oct 22 00:21:50 udoo-x86 nodejs[11709]: the module (for instance, using `npm rebuild` or `npm install`).
    
     
  5. maxromanovsky

    maxromanovsky New Member

    Joined:
    Oct 23, 2018
    Messages:
    7
    Likes Received:
    1
  6. waltervl

    waltervl Well-Known Member

    Joined:
    Dec 12, 2015
    Messages:
    1,885
    Likes Received:
    462
  7. maxromanovsky

    maxromanovsky New Member

    Joined:
    Oct 23, 2018
    Messages:
    7
    Likes Received:
    1
    Already did before writing to the forum.
    Anyway, after playing around did:
    Code:
    apt remove udoo-iot-cloud-client udoo-web-conf
    rm -rfv /opt/udoo-iot-client
    apt install udoo-iot-cloud-client udoo-web-conf -y
    
    Then:
    Code:
    $ journalctl -u udoo-iot-cloud-client.service
    Oct 28 11:16:43 udoo systemd[1]: Started UDOO IoT Client Node.js Service.
    Oct 28 11:16:44 udoo nodejs[8150]: module.js:549
    Oct 28 11:16:44 udoo nodejs[8150]:     throw err;
    Oct 28 11:16:44 udoo nodejs[8150]:     ^
    Oct 28 11:16:44 udoo nodejs[8150]: Error: Cannot find module 'node-ini'
    Oct 28 11:16:44 udoo nodejs[8150]:     at Function.Module._resolveFilename (module.js:547:15)
    Oct 28 11:16:44 udoo nodejs[8150]:     at Function.Module._load (module.js:474:25)
    Oct 28 11:16:44 udoo nodejs[8150]:     at Module.require (module.js:596:17)
    Oct 28 11:16:44 udoo nodejs[8150]:     at require (internal/module.js:11:18)
    Oct 28 11:16:44 udoo nodejs[8150]:     at Object.<anonymous> (/opt/udoo-iot-client/configurator.js:1:73)
    Oct 28 11:16:44 udoo nodejs[8150]:     at Module._compile (module.js:652:30)
    Oct 28 11:16:44 udoo nodejs[8150]:     at Object.Module._extensions..js (module.js:663:10)
    Oct 28 11:16:44 udoo nodejs[8150]:     at Module.load (module.js:565:32)
    Oct 28 11:16:44 udoo nodejs[8150]:     at tryModuleLoad (module.js:505:12)
    Oct 28 11:16:44 udoo nodejs[8150]:     at Function.Module._load (module.js:497:3)
    Oct 28 11:16:44 udoo systemd[1]: udoo-iot-cloud-client.service: Main process exited, code=exited, status=1/FAILURE
    Oct 28 11:16:44 udoo systemd[1]: udoo-iot-cloud-client.service: Failed with result 'exit-code'.
    Oct 28 11:16:44 udoo systemd[1]: udoo-iot-cloud-client.service: Service hold-off time over, scheduling restart.
    Oct 28 11:16:44 udoo systemd[1]: udoo-iot-cloud-client.service: Scheduled restart job, restart counter is at 4.
    Oct 28 11:16:44 udoo systemd[1]: Stopped UDOO IoT Client Node.js Service.
    Oct 28 11:16:44 udoo systemd[1]: udoo-iot-cloud-client.service: Start request repeated too quickly.
    Oct 28 11:16:44 udoo systemd[1]: udoo-iot-cloud-client.service: Failed with result 'exit-code'.
    Oct 28 11:16:44 udoo systemd[1]: Failed to start UDOO IoT Client Node.js Service.
    
     
  8. maxromanovsky

    maxromanovsky New Member

    Joined:
    Oct 23, 2018
    Messages:
    7
    Likes Received:
    1
    Okay, installing nodejs v6 did the trick: https://www.ubuntuupdates.org/ppa/nodejs_6.x
    nodejs bundled with bionic was too new for udoo node modules (which are installed into /opt/udoo-iot-client/node_modules via apt package and were compiled for the specific nodejs version).
     
    waltervl likes this.

Share This Page