Internal Arduino IDE

To develop sketches for SAM3X cores we provide the same way to program Arduino DUE. You can use the internal Arduino IDE preinstalled on the UDOObuntu releases.

After you connected the board and boot the UDOObuntu 2 desktop environment:

  1. Start -> Programming -> Arduino IDE or the Arduino IDE desktop link.
  2. Tools -> Board -> UDOO QDL (Arduino Due)
  3. Tools -> Port -> /dev/ttymxc3
  4. File -> Examples -> Basics -> Blink
  5. Click on "Upload" button.
  6. Wait "Compiling sketch..." until "Upload is complete".

As you can see this is the same procedure you usually use with all the others Arduino board.

This page was last updated on Wednesday, May 10, 2017 at 10:24 PM.